cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

Include Folders in single MSI file without using disk1 folder structure

Hello -

I am new to Flexera software. I would like my msi file to be a single MSI file that when double-clicked:

1) runs setup
2) creates 3 subfolders within the program files/projectname folder
3) creates the files indicated in the setup

All is getting created just fine, but instead of one MSI file, currently the output Flexera generates for me goes to a folder stuctured like this:

--------------------------------------------------------

\Express\DVD-5\DiskImages\DISK1
0x49 (configuration file)
projectname.exe (the MSI file)
setup (app)
setup (config)

\program files

-------------------------------------------------------

How can I achieve just one file for setup instead of a folder containing the setup?

Thanks in advance.
Labels (1)
0 Kudos
5 Replies
Highlighted
Pilgrim

Re: Include Folders in single MSI file without using disk1 folder structure

Instead of the DVD-5 media type, use the SingleImage media type. On the Build tab for that release, in the Compression setting, select Compress. And on the Setup.exe tab, make sure that the Setup Launcher setting is configured to be No.

That should give you a single .msi file that installs the files as you described.

I hope that helps.
0 Kudos
Highlighted
Pilgrim

SingleImage not produced

DebbieL wrote:
Instead of the DVD-5 media type, use the SingleImage media type. On the Build tab for that release, in the Compression setting, select Compress. And on the Setup.exe tab, make sure that the Setup Launcher setting is configured to be Yes.

That should give you a single .msi file that installs the files as you described.

I hope that helps.


I am using the Limited edition of InstallShield and have done what you said to do to make all installation files to be included in one executable (e.g., setup.exe) but I can't get it right. For one thing, after compiling there is only the ...\Express\DVD-5\DiskImages\DISK1 and no SingleImage? Is this only available in other versions of InstallShield? Thanks
0 Kudos
Highlighted
Pilgrim

Re: Include Folders in single MSI file without using disk1 folder structure

farrokhrt,

We have a dedicated forum for users of the Limited edition of InstallShield, since that edition is quite different than the other editions. I recommend posting your questions there:
https://community.flexerasoftware.com/forumdisplay.php?264-InstallShield-Limited-Edition-for-Visual-...

The SingleImage media type is available in the Limited edition. I suspect that you need to select the SingleImage media type through the Configuration Manager. It sounds like DVD-5 is currently selected in your solution.
0 Kudos
Highlighted
Pilgrim

Re: Include Folders in single MSI file without using disk1 folder structure

DebbieL wrote:
farrokhrt,

We have a dedicated forum for users of the Limited edition of InstallShield, since that edition is quite different than the other editions. I recommend posting your questions there:
https://community.flexerasoftware.com/forumdisplay.php?264-InstallShield-Limited-Edition-for-Visual-...

The SingleImage media type is available in the Limited edition. I suspect that you need to select the SingleImage media type through the Configuration Manager. It sounds like DVD-5 is currently selected in your solution.


Thank you for your help. I am new to InstallShield and just searched Felexera site for my issue. I'll remember to use the suggested URL in the future. You Configuration Manager target change did exactly what I wanted to do! Thanks again.
0 Kudos
Highlighted
Pilgrim

Thank you. That definitely did the trick.

DebbieL wrote:
Instead of the DVD-5 media type, use the SingleImage media type. On the Build tab for that release, in the Compression setting, select Compress. And on the Setup.exe tab, make sure that the Setup Launcher setting is configured to be Yes.

That should give you a single .msi file that installs the files as you described.

I hope that helps.


Thank you, Debbie. That definitely did the trick.
0 Kudos