cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mashkov_dmitry
Level 4

How can I disable COM extraction completely?

I am trying to add a large number of exe/dll files (specifically, SQL Server bits) into the setup project. InstallShield initiates its "artificial intelligence" and attempts to scan everything and fails:
Error 2 -6017: The build was unable to extract COM information; make sure that you are running as Administrator. ISEXP : error : -6017: The build was unable to extract COM information; make sure that you are running as Administrator.

I don't need this at all, can I disable this functionality?
0 Kudos
21 Replies
Lenwin
Level 10

Right click on the file you have added in the file view and select Properties

Select the COM & .NET Settings tab

Here you can set the value of Scan at build field to None.
0 Kudos
mashkov_dmitry
Level 4

That's not a solution. As I wrote, there's a lot of files. Not 2 or 3, but hundreds - extract SQL Server bits. So I need to disable that function completely, not for file-by-file.
0 Kudos
Lenwin
Level 10

You may Navigate to the Options -> .Net tab and here set the Value of .NET scan At Build Property to None.

It will only be applicable to files which will be added in future.
0 Kudos
mashkov_dmitry
Level 4

I already tried that. That has no effect - InstallShield ignores this.
0 Kudos
Lenwin
Level 10

We performed the following steps.

Step 1:

Created an ISLE Project.

In Options -> .Net tab the Value of .NET scan At Build Property was set to dependencies and Properties.

We added a file which had .NET dependency.

After adding the file we changed the value of .NET scan At Build Property to none.

Added another file which had .NET dependency.

When the setup was built we came across this message

ISEXP : warning : -6245: One or more of the project's components contain .NET properties that require the .NET Framework. It is recommended that the release include the .NET Framework.


Step 2:

Created a New Project.

Here set the value of .NET scan At Build Property to none.

Then added the file which have .Net dependies.

We did not come across any error message.


Could you try setting the value of .NET scan At Build Property to none before adding any files to the project and check if you are coming across the same error message.
0 Kudos
mashkov_dmitry
Level 4

Hello Lenwin

This does not change anything - it still attempts the extraction: "Error 2 -6017: The build was unable to extract COM information; make sure that you are running as Administrator. ISEXP : error : -6017: The build was unable to extract COM information; make sure that you are running as Administrator.

"
0 Kudos
Lenwin
Level 10

Hi,

Could you get back to us with the Project file (.isl file) and the (.Net and Com dependency) files with which you are facing issues while building the project so that we can investigate further.

Thanks,
Lenwin
0 Kudos
mashkov_dmitry
Level 4

Yes, I can attach the project, but as for the files - they're quite large. Do you have an FTP for the upload?
0 Kudos
mashkov_dmitry
Level 4

Attached ZIPped ISL file.
0 Kudos
Lenwin
Level 10

Hi Mashkov,

Thank you for getting back to us with the project file.

Since you wish to change the scan settings for .NET and COM dependencies after adding the files to the project, we would like to inform you that this task can be achieved with ease in the Premier and Professional editions of InstallShield. Here we don't have to set the option for every file that exists instead in the components view there is an option to modify the scan settings for .Net and COM dependencies. Once set the setting would get applied to all the files in the component.

You may also modify the settings of the scan process using the ISWiComponent Object (DotNetScanAtBuild) ( In Premier and Professional Edition of InstallShield)

Kindly review the help articles given below.

http://kb.flexerasoftware.com/doc/Helpnet/installshield16helplib_sp1/IHelpAutoISWiCompObject.htm

http://kb.flexerasoftware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=installshield16helplibsp1-ComponentSettingshtm&sliceId=&docTypeID=DT_MACROVISIONHELPNET_1_1&dialogID=87071062&stateId=0%200%2087069236

As suggested earlier in InstallShield limited edition we would be able to achieve this by either of the below two options only.

For an existing project with files added, only option is to Set the value of Scan at Build field to None for every file added. I agree this would be a cumbersome process if there are multiple files.

The other option which works better here is to set Default .Net Scan at Build File Setting to None and then add the files to a new project.

Thanks,
Lenwin
0 Kudos
mashkov_dmitry
Level 4

Unfortunately, as I wrote earlier, the second option (to set Default .Net Scan at Build File Setting to None and then add the files to a new project) does not work - InstallShield does not honor it. Why?
0 Kudos
Lenwin
Level 10

Hi Mashkov,

Kindly review the attached sample projects.

Sample Project with no warning Message

In the sample project scan2 we do not come across the warning message as we had set the option of scanning for .NET dependencies to none before adding any files to the project. (Default .Net Scan at Build File Setting to None).

Kindly open the scan2.sln file in Visual Studio 2010.

In the Solution Explorer, expand #2 “Specify Application Data”.

Double click on “Files” to open the Files view

Add a text file and build the solution.

Here we do not come across the warning message during the build process.

Sample Project with a warning Message

In the sample project scan1 we come across a warning message as we had set the option of disabling the scan for .NET dependencies after adding the file to the project. (Default .Net Scan at Build File Setting to None).

Kindly open the scan1.sln file in Visual Studio 2010.

Double click on Files under #2 Specify Application Data.

Add a text file and build the solution.

Here we come across the warning message during the build process.

If the issue still persists then we request you to let us know the exact steps which you have followed and kindly get back to us with a sample project (visual studio .sln and associated files) so that we can replicate the issue at our end.

Thanks,
Lenwin
0 Kudos
mashkov_dmitry
Level 4

Hello Lenwin

1. Sometimes, when trying to open the solution, VS2010 crashes with NullPointerReference exception 😞
2. Scan2 does not build right after unpacking because it refers to SmartDev.exe which is not included. I have removed it from the project.
3. When adding the .txt file, build succeeds.
4. Now, I add real files (executables, not text files!) and the error ideally reproduces.
Have you tested this with non-text files?
0 Kudos
Lenwin
Level 10

Hi Mashkov,

I have attached the SmartDev.exe file. Kindly add this file to the sample project scan2 and build the project.
You should not encounter the warning message when you build the project.

Kindly let us know the results.

Thanks,
Lenwin
0 Kudos
mashkov_dmitry
Level 4

SmartDev error disappeared. Original issue is still present.
Please see attached files.
0 Kudos
Lenwin
Level 10

Hi Mashkov,

Thank you for getting back to us with the project file and the log file.
From the log file we do see that you encounter the ISEXP : fatal error -6017 error message during the build process.

This error message might be related to the files which have been added to the project.

Hence we request you to send us a sample project where you encounter the same error message with only a few files added .
Kindly send us all dependent files added to the sample project.(Sample project file folder Ex: Found in location C:\Documents and Settings\Username \My Documents\Visual Studio 2010\Projects which includes .sln file and .isl file.)

This would help us to replicate the issue at our end

Thanks,
Lenwin
0 Kudos
mashkov_dmitry
Level 4

Hello Lenwin

1. I already wrote that this is reproduced with SQL Server bits. I am pretty sure you have SQL Server at Flexera so I do not see any need to upload the huge set of data. But if you insist - I will do that.
2. Anyway, this must NOT depend on files I add to the project because the default setting is "no scan". Why does InstallShield ignore it?
0 Kudos
Lenwin
Level 10

Hi Mashkov,

Kindly provide us the following information so that we can investigate further.

Could you let us know how you are adding the files to the project. Is it by dragging and dropping the files or by Right-clicking in the files view and adding the files.

Could you let us know through which view you are adding the files to the project.

Kindly let us know if you are an administrator on your machine. If you are not an administrator do you still come across this error if you login as an administrator?

Could you let us know the desired behavior you are expecting for handling COM information. Is it marking it as self-registering? Or Extract COM information as soon as the file is added? (Rather than at build time)

Kindly let us know the version of SQL Server you are trying to add. We would like to ensure that we are testing with the exact bits.

Thanks,
Lenwin
0 Kudos
mashkov_dmitry
Level 4

On you questions:

1. Drag and drop into the Files window, into the folder tree (any folder).
2. I am not running as administrator, I can test this with elevated permissions.
3. I expect that, if I have set the option to not extract COM information, InstallShield will not make _any_ assumptions regarding the added files unless explicitly specified by changing the file properties and treat file just like file - no extraction or other intelligence - at any time.
4. SQL Server 2008 Express with Advanced Tools.
0 Kudos
Lenwin
Level 10

Hi Mashkov,

Thank you for your response.

Could you kindly test the project with administrator rights and check if you come across the same error message.

Kindly create a new project when you log in as an administrator and set the option of scanning for .NET dependencies to none before adding any files to the project.

Thanks,
Lenwin
0 Kudos