[Incident]: Some users report they are unable to access the case portal. Please see this community notice for more information.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
adirisr
Level 3

Getting ISDEV : fatal error -6199: Internal build error during Jenkins pipeline build

Hi,

I am trying to build .ism files using jenkine pipeline build an encounter the followingspProject->Open Failed
ISDEV : fatal error -6199: Internal build error
Unspecified error

However, when trying to build .ism manually it does succeeded !!As well as project file was set to XML.

Can someone advice??

 

Labels (1)
0 Kudos
12 Replies
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi adirisr,

 Please make sure your jenkins agent run as same user as who installed installed shield, like if user X is installed installshield in machine1 then your jenkins agent also login with same user x credentails and then try build and see it works or not.

 

Kind Regards,

0 Kudos

Thanks for replying,

Is it possible to change the installeshield credentials while it is already installed or i must uninstall and reinstall??

0 Kudos
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

Uninstall and re install with same as jenkins agent credentials and then try.
0 Kudos

Tried that ...and issue persist :((

0 Kudos
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

Please check the project related files and ism files are not opening in visual studio or any other tools, make sure you close all the files and projects and the tools and try building

 Even after doing that if still fails then please Pass an additional parameter -v to the IsCmdBld.exe when it is failing. This will provide some more information about the failure.

-v parameter will help you get details verbose build log and check logs for failure cause

https://docs.revenera.com/installshield21helplib/helplibrary/ISCmdBldParam.htm

 

Are you using full IS version or SAB Installshield to build project using Jenkins?

 

0 Kudos

The error i mentioned is after adding -v parameter...
0 Kudos
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

Please share the complete installation log, did you check the files are not opened in any tool 

0 Kudos

Thanks for reply..

Yes we checked and the files not opened via VS or any other app.

Is there any way to share the log with you in secure manner??

0 Kudos
varul
Revenera Moderator Revenera Moderator
Revenera Moderator

Please turn of anti virus or any security software running in your machine, you can share the part of log here in attachments,

else you can go ahead and raise a support case.
0 Kudos

Sent you part of the log privately.

I disabled AV as well as windows defender and still no luck..
0 Kudos

Issue persist..is there any other support member that can help me resolve it??? 

0 Kudos

my version is installshield premier 2016
0 Kudos