cancel
Showing results for 
Search instead for 
Did you mean: 
ayeleth100
Flexera beginner

Get IIS version

I upgraded InstallShield from version 12 to 2011 Premier and get the following error when compiling:
'IISRTGetIISVersion' : undefined identifier

This function works fine in version 12, how to fix it for version 2011?

Thanks in advance.
Labels (1)
0 Kudos
6 Replies
Roman1
Flexera beginner

Re: Get IIS version

Just add

\Script\IISRuntime\Lib\IISRT.obl

in Build settings (Build\Settingz menu)
0 Kudos
ayeleth100
Flexera beginner

Re: Get IIS version

I think it is already defined, see attached file.
0 Kudos
Roman1
Flexera beginner

Re: Get IIS version

What about, if you use this notation?

\Script\ifx\Lib\ifx.obl,\Script\ISRT\Lib\isrt.obl,\Script\Isrt\Lib\IISRT.obl
0 Kudos
ayeleth100
Flexera beginner

Re: Get IIS version

No change, I get the same error message.
0 Kudos
Roman1
Flexera beginner

Re: Get IIS version

0 Kudos
Roman1
Flexera beginner

Re: Get IIS version

Try this:

prototype GetIISVersion(BYREF NUMBER, BYREF NUMBER);

function GetIISVersion(nIISMajor, nIISMinor)

STRING svResult;
NUMBER nvType, nvSize;

begin
RegDBSetDefaultRoot(HKEY_LOCAL_MACHINE);
if RegDBGetKeyValueEx ("Software\\Microsoft\\InetStp", "MajorVersion",
nvType, svResult, nvSize) < 0 then
nIISMajor = 0;
nIISMinor = 0;
else
StrToNum(nIISMajor, svResult);
RegDBGetKeyValueEx ("Software\\Microsoft\\InetStp", "MinorVersion",
nvType, svResult, nvSize);
StrToNum(nIISMinor, svResult);
endif;
end;

Now you have nIISMajor and nIISMinor.
0 Kudos