[Incident]: Some users report they are unable to access the case portal. Please see this community notice for more information.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Gelsing
Level 2

Files in the Application Target Folder are not getting installed

 

I have an InstallShield installScript project. When I run the project the files in the "Application Target Folder" are not getting copied to to the target directory during installation. Does anyone know what might the issue might be?

Side notes:

In the Project Assistant tab 
Under the "Destination Computer" Icon
Under "Application Target Folder" (Here is where I have several files that will be copied to the target folder)
The files are not getting copied though when the installation occurs??

0 Kudos
1 Reply
markhug
Level 4

The files shown in "Application Target Folder" do not necessarily reflect what will actually be installed.
I sometimes find it useful to look at the data1.hdr file (which is generated when a release is built).  To do this:
a. S
elect "Installscript>Cabinet/Log file viewer menu item (under "Tools" menu)
b. Browse to the built data1.hdr file that built when you built the Release (it will be in <project folder>\Media\<release name>\Disk Images\Disk1\ ) .
c. Use the resulting UI to determine if your files were included in the release.  I find it easiest to use the "Report" option in the Viewer to find out if your files are actually present in the release.   That may help guide you to the reason for the problem.

Notwithstanding.... to troubleshoot, one may proceed as follows:
1. Switch from the "Project Assistant" tab to the "Installation Designer" tab.

2. Under Organization>Setup Design, ensure that there is at least one feature listed.  The "include in build" is set to "Yes" by default.  Ensure that is is set to Yes.  If it is set to no, set it to "Yes, OR ensure that you have handled enabling it somewhere in your install script. 

3. Under that feature, ensure and that there is at least one component, and that there are the required files listed under that component.  Verify the "Destination" field is set to something valid (usually <TARGETDIR>) and verify that the string representing the TARGETDIR (or whatever is in the "Destination" field) is something sane.  You can set the initial value for TARGETDIR under "Installation Information>General Information".

4. Under Organization>Setup Types, ensure that the required feature(s) is selected for each Setup Type that is available.  If a sub-feature is selected, its parent must be selected as well (although the UI should automatically enable the parent for you if you enable the child).

5.  Under Media>Releases ensure that the feature is enabled.  This can only be done in the Release Wizard within the "Features" step.  If the feature's "Include in build" option was set to Yes, then select the "Use the "Include in Build" feature property to determine inclusion" radio button.  Otherwise, you will need to select the "Specify the features to be included below" radio button in order to select the feature you want to be included in the release.

I hope that helps.

0 Kudos