Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

Failed to marshal script action.


We are having an issue on some systems with one of the actions in a VBScript CA.

It appears to be related to COM objects and possibly the security on the system blocking something when it gets to these lines of the custom action when running the MSI.

We have worked around this on one system by changing access levels on the component "immersive shell" in component services, but the same fix does not apply on another client system.

The error we see in log is below,


And snippet from the CA,


The actual VBScript of the custom action runs perfectly on the faulting system when tested separately using the CScript engine on OS.

We had been informed in a Flexera workshop that InstallShield wraps up it's own VBScript engine as part of the package so it would make sense that whatever way it is trying to invoke the script that it is possibly being blocked by the system or cannot access some COM object, and that there is a policy on the operating system we need to modify.

There are no errors in the Event Viewer to indicate exactly what is happening.

Any help would be much appreciated in narrowing this down.

Thank you,



Labels (1)
0 Kudos
(6) Replies
Level 4

Did I say something to upset someone?
0 Kudos

Hi @conorhoran ,

Definitely not 🙂

  • Which Operating System you face problem with?
  • The above error is due to windows unable to create COM object to proceed further.There are some recommendations to get this patch:
  • I would also suggest to do this:
  • C:\Windows\System32\msiexec.exe /regserver
    C:\Windows\SysWOW64\msiexec.exe /regserver



0 Kudos

Hi Jenifer,

Thanks for reply 🙂

We have tried un-registering and re-registering the msiexec but no effect.

We have also looked for relevant patch following your link but we are on Windows 10 and none is available.

Details of system below (note this is a VM of physical machine so some hardware will be different),


This PC is domain joined hence the reason we thought it might be a policy on the system blocking the installer.

We have removed the VM from the domain and removed the policies via the registry to test this but still getting same behaviour.

We will try enabling the Windows Updates and see if it pulls down any patches and re-test.

On our own domain we were seeing similar behaviour and the fix was to give permissions on the following in Component Services,


We have done this on this machine and it has not solved the issue.

There doesn't seem to be anything in EventViewer showing an error when running this installer bar the standard MSI events saying it is installing and failing.

It's a bit of a pickle this but I'll buy you a drink if you can help us solve it.


0 Kudos

In response to this,

We have applied all pending Windows Updates and still have issue.

You'll have to excuse me too but I searched some of your other posts and noticed one where you suggested using the debugger to someone having another issue.

It is at this link here

We had seen this previously but believed it was only for debugging Installscript actions but if it is something we could use in this case it would be very helpful.

The instructions are not completely clear as to whether the files need to exist in the same folder as the setup.exe but we have been trying to follow them and run the setup.exe with /d but not sure if it is working or are we missing something.

If you think it is something that will help we can pursue this option further. I'm sure it will be useful for any errors in future too.


0 Kudos

Hi @conorhoran ,

  • ISDbg.exe is only for installscript and its associated file debugging,not for msi engine's.
  • Since Installshield has its own script engine,debugging support is restricted to that
  • Few suggestions on re-registering the dll:regsvr32 oleaut32.dll
  • It is but difficult to narrow down the problem ,since it is machine and VBScript CA specific
  • Feel free to reach support ,so that they can sort out via remote session




Thanks Jenifer.

We have tried the oleaut32.dll registration and even re-installing msvbvm50 but it did not have any effect.

We will open a ticket with support and see what our options are.

Thanks for your suggestions though, they have been helpful all the same.

Take care.
0 Kudos