cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

Error when installing on system without .NET 4.0?

Hi,

I have an installer with Installer actions from a .NET Windows Application. The application is built using the .NET 2.0 framework.

When I generate an MSI and try to run it on a system without .NET 4.0 installed, I get an "Error 1001: Unknown Error" message (I get a second one when the rollback is attempted as well). Prior to this error, everything seems to install successfully (but it gets rolled back when the error dialog is confirmed). I'm able to confirm that it's the lack of .NET 4.0 that's causing the issue - once I install .NET 4.0 the MSI runs fine.

Nowhere (that I can find at least) in the Installshield project is .NET 4.0 specified.

The only lead I have is that an file called _isconfig.xml is automatically generated, with the following contents:










Changing the file does nothing - it just gets changed back when I rebuild the MSI.

Is there a way to modify the above file directly, or tell Installshield to put to use the .NET 2.0 framework instead of 4.0?
Labels (1)
0 Kudos
1 Reply
Highlighted
Pilgrim

Error when installing on system without .NET 4.0?

To resolve your issue, I would suggest including a attributable for .net 4.0. This can be done under step 2 for redistributables. Just checkmark the box next to it.

I think that this may not be fully addressing the issue you have tho. I think your issue is that you would like to know why your installation requires .net 4.0 to be installed.

Although, knowing that the install fails when .net 4.0 is not installed would indicate that the installation has some dependency on .net 4.0 being installed.
0 Kudos