umeryounas
Level 2

Error to add registry entries in 64bit Windows 7

Hello

i have a windows application and want to install it in x86 and x64 operating systems. i have created to basic MSI projects, one for x86 and 2nd one for x64, having some registry values that should have to be added in the registry under (HKEY_LOCAL_MACHINE -> SOFTWARE -> [productname]). while installing on 32bit operating system it works perfectly fine. but when i tried to install it on 64bit operating system, it didnt works. the registry key values are not been added in the registry.

Can any one help me in this matter. i have tried from many source but didnt get this issue resolve.

Thanx in advance.

Umer
Labels (1)
0 Kudos
3 Replies
MichaelU
Level 12 Flexeran
Level 12 Flexeran

Have you marked your components and installation as 64-bit?
0 Kudos
phenrichs
Level 4

Have you looked in the Wow6432Node?

I have a similar issue. I have a 32bit app (using installscript not msi) and I create all my keys normally in the wow but I need one set of keys to remain up in the 64bit area under SOFTWARE and I cannot seem to figure out how to get around the 6432 translation.
0 Kudos
overlordchin
Level 6

phenrichs wrote:
Have you looked in the Wow6432Node?

I have a similar issue. I have a 32bit app (using installscript not msi) and I create all my keys normally in the wow but I need one set of keys to remain up in the 64bit area under SOFTWARE and I cannot seem to figure out how to get around the 6432 translation.


By default in a 32bit installer the registry keys will auto go to the wow6432 location on a 64bit system. You cannot address the 64bit area in a 32bit installer. You can only address the 64bit area in a 64bit installer meaning you have to flag it as such. I believe but I am not certain a 64bit installer can have 32bit components but not the other way around.
0 Kudos