Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Error 1721 in a Custom Action

I have created a Custom Action named InstallFoomatic, which calls a third party software's Install.exe to do the work. The third party Foomatic software is loaded in the Support Files (Language Independent) pane. Whenever the installer is run (WinXP only so far, I have not yet tried Win7) it dies during the execution of this CA with the error:

Error 1721.There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor. Action: blah, blah, blah

The CA is configured as follows:

  • Created a CA based on "New EXE > Path referencing a directory".
  • Working Directory:
  • Filename & Command line: "[SUPPORTDIR]\Install.exe" -license "[FoomaticLicenseKey]"
  • Return Processing: Synchronous (Check exit code)
  • In-Script Execution: Deferred Execution
  • Install Exec Sequence: After StartServices
  • Install Exec Condition: &Foomatic = 3
  • everything else was left at the default

Note the use of the Foomatic Feature in the condition.

Google reveals some tips, the most useful of which are and

Based on those links I tried changing the sequence all over the place, keeping it between InstallInitialize and InstallFinalize, but this did not help. On the chance that this was permissions-related I set the In-Script Execution from "Deferred Execution" to "Deferred Execution in System Context", but to no avail.

One interesting thing is that if I leave the installer's error message up and open a command prompt, I can navigate to the SUPPORTDIR and see the expected files there. I can even run Install.exe manually, passing in the required arguments, and it does what it is supposed to do. So it seems that the files are there, but perhaps because I'm doing it in a command prompt makes a difference somehow.

Does anyone have any ideas what to try next?
Labels (1)
0 Kudos
(3) Replies
Flexera Alumni

As a stab in the dark, does it make a difference if you set Working Directory to SUPPORTDIR, too? Or for testing, try including and launching notepad.exe under the same conditions?

(Quite right, though, that an action making a system change should be scheduled for deferred execution, usu. in system context.)
0 Kudos
Level 3

I tried setting the Working Directory as follows:

  • [SUPPORTDIR] - Error 2727.The directory entry '[SUPPORTDIR]' does not exist in the Directory table.
  • SUPPORTDIR - It works! Oddly, this one is not in the dropdown list but whatever.

Thanks for the tip. Now it's on to 64-bit installs -- wish me luck...
0 Kudos
Level 2

Error 1721 is caused by Windows UAC set it to Never Notify.

Method 1: Disable and Turnoff UAC in Windows 7 from Control Panel
1. Access User Control Panel from Start Menu -> Control Panel -> User Accounts and Family Safety -> User Account

2. Click on
User Account Control settings link.

3. Move the Slider to Never Notify

4. Click OK to make the change effective

5. Reboot.

Log back on and Rerun your installer and the custom actions won't fail.
0 Kudos