Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 5

Error 1 -1001: Error opening MSI database F:\user\Documents\MyProgram.msi

Jump to solution


I have been using this computer for years to compile deployment packages with no issues. I am using InstallShield 2015 Limited Edition for Visual Studio 2013 Community.  But lately, I started getting the error message above. Even though this error message, the project compiles three files, Setup.exe, setup.ini, and Myprogram.msi.

But when I run the created executable, it tries to install the program (!),  and looks for the msi file at some obscure location. Although I cancel the installation, this, the program eventually runs.

I unregistered and registered the  msiexec.exe file. I run sfc /scannow with no errors.  I have v5.0 of msiexec.exe.  

The project runs on a Win 10 computer without any error. So the problem is with the Msiexec. exe on this Win 7 Pro computer, not the installation project.

What's wrong? I am stuck! Please help.

0 Kudos
(1) Solution
(6) Replies

Hi @Anadolu ,


 See whether you can resolve this issue by repairing the system registry:


0 Kudos

Hello Banna_k,

Thank you for your reply. I run it. I chose the file that was already installed, and that I am trying to create a new installation file. I chose the uninstall option. The tool uninstalled it. Then I run IS to create a new installation file, it still gave me the same -1001 error.  

I believe my problem is not installing/uninstalling that this diagnostic tool would resolve. I am getting this error when I try to create an installation file in VS 2017 using IS 2015  LE. Instead of creating a single setup.exe file, the IS creates three files with -1001 error. On top of that, I cannot even run the same program that was installed before, because it tries to install itself again!  You are possibly right that some registry entry is messed up. But which one?



0 Kudos

Hi @Anadolu ,


It looks like some problem with your system:  I dont have the exact solution for this, I can only give some suggestions:

1- Can you try to repair/reinstall windows installer.

2- Re register your msi.dll/msiexec.exe

3- See the below link which talks about the same error, but the same thing you did in last reply

Lastly, I would like to know how your creating installer in VS 2017 using IS 2015 LE ("I am getting this error when I try to create an installation file in VS 2017 using IS 2015  LE")


0 Kudos

Hello banna_k,

1) I do not know how to uninstall/install msiexec.exe but I run sfc /scannow without any errors. I stopped and restarted windows installer service.

2) I followed instructions given a MS site to deregister/register the msiexec.exe file with no avail.

3) I followed the  instructions in the link with no success.

I use VS2013 community not VS 2017 with IS 2015 LE, I’m sorry, my mistake. The installation project that has the -1001 problem on the Win 7 computer works fine on a Win 10 computer creating a setup.exe file that works to install the program on the Win 7 computer. But I cannot create a setup.exe program that runs successfully on this computer.




0 Kudos

Hi @Anadolu ,


 See the below KB article helps to resolve the issue:

0 Kudos

Hello banna_k, Your patience paid off. I could not re-register msi.dll but after re-registering the scrrun.dll file, the -1001 error is gone, and the setup.exe file is created successfully. Thank you very much.

0 Kudos