cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
chriscw
Level 6

DotNet 3.5 required messages when installing to Windows 8 (DotNet 3.5 is NOT actually

Several of my install projects when run on Windows 8 or 8.1 flash up multiple messages saying that features of our product require the DotNet 3.5 framework to be installed, files which trigger these messages include PDF files and CHM file as well as some more obvious types such as EXE files. If the warnings are ignored and the product is installed it works perfectly without DotNet 3.5. The same projects do not flash up any error message if the setups are run on a copy of Windows 7 which has had DotNet 3.5 removed.

This matters to us because some of the users of our products require to be able to install without an internet connection and it does not seem to be possible even using the full downloaded version of the DotNet 3.5 prerequisite or any other Full DotNet 3.5 download I can find without a connection to Windows Update.

Has anyone else run in to a similar issue and if so did you find a solution?
Labels (1)
0 Kudos
2 Replies
chriscw
Level 6

What would really help me would be a way to stop Installshield from checking for files it thinks are missing during the file copy process. I have had a look and turned off the checks that I can find but we are still getting these spurious errors when installing on Windows 8.
0 Kudos
chriscw
Level 6

I have had response on the Microsoft partner program web page, not an answer but its being looked at. I note from other forums that this is a widespread issue, the need to install DotNet 3.5 without an internet connection. In our case of course we only need it to stop Installshield from erroneously indicating a need for it.

I assume that no Flexera staff ever look at these forums or one might expect that some of the issues raised might occasionally get some sort of response.
0 Kudos