cancel
Showing results for 
Search instead for 
Did you mean: 
alanrickman
Pilgrim

Debugging Installscript Custom Actions

Hi all,

I have an Installscript MSI project (2008) with several IS Custom Actions. I am able to successfully debug these on the development machine where Installshield is installed.

However if i attempt to debug on a test machine the break points in the custom actions never get hit. I can see the custom actions are being executed from the log file and by inserting message boxes.

I have added this registry entry as suggested in the forums / support pages.

[HKEY_CURRENT_USER\Software\InstallShield\ISEngine14.0]
"DebugISCustomActions"=dword:00000001

Any body have any ideas?

Thanks,
Alan
Labels (1)
0 Kudos
4 Replies
Highlighted

Re: Debugging Installscript Custom Actions

I've found that registry setting helpful when debugging deferred CA's on my development machine but to debug on a clean machine you'll still need additional components.

I don't have IS2008 installed but in IS2009 there is a help topic called "Debugging an Installation on Any Computer" that taks about copying ISDbg.exe ( and ISDbg.chm if you want ) to your clean machine and then calling it with /regserver to register it.

You will also need Script Files folder created during the build but not deployed. I believe if you put them in the same folder as setup.exe and apply your reg file that it should work.
0 Kudos

Re: Debugging Installscript Custom Actions

Hmmm, I'm almost there.

On a dev machine with InstallShield, I can apply the registry setting and copy the .MSI, and contents of Script files to a folder. With InstallShield *NOT* running I can run the MSI and the debugger will come up.

On a clean machine with ISDBG registered and running, I can do the same thing as above. Initially ISDBG says 'No Debugging Session' but when I start my MSI it says 'Break' If I tell ISDBG to "step into" I get an unhandled win32 exception ( 2128 )
0 Kudos
alanrickman
Pilgrim

Re: Debugging Installscript Custom Actions

Thanks for the reply.

Probably should have said this in my first post but I can debug the rest of my script ok.

I've copied my MSI and Script files to the test machine along with isdbg.exe and have registered isdbg.exe with the /regserver switch.

I launch my setup with "c:\\setup.exe" /d"" at which point isdbg.exe launches along with setup.rul loaded and i can then step into the code.

On my test machine the break point in my installscript custom action isn't hit yet on my development machine it is Smiley Sad
0 Kudos
alanrickman
Pilgrim

Re: Debugging Installscript Custom Actions

Has anybody any ideas on this...?

It's becoming quite frustrating having to debug my CAs with message boxes. I really can't fathom out the problem.

I can debug the CAs ok on the machine where IS2008 is installed either by
1) Clicking debug from within the IDE
2) Starting the install like so: "\setup.exe" /d""

I've now tried debugging CAs on half a dozen other machines without success, making sure ISDbg.exe is registered and the ISDebugCustomActions registry entry is present. I'm able to debug all of my installscript on these machines just not the custom actions.

Thanks,
Alan
0 Kudos