Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Command line build fails - Resolving Visual Studio .NET project output


When building the solution with from the command line (i.e. our build server) the setup project fail to build. Works fine from within VS2012.

I can see that others have had the same problem but without any replies or solutions. Is there one?

Anyone from flexera checking these forums?

5>------ Build started: Project: Setup, Configuration: SingleImage ------
5>Created release folders
5>AdminExecuteSequence table successfully built
5>AdminUISequence table successfully built
5>AdvtExecuteSequence table successfully built
5>AdvtUISequence table successfully built
5>InstallExecuteSequence table successfully built
5>InstallUISequence table successfully built
5>Directory table successfully built
5>Feature table successfully built
5>FeatureComponents table successfully built
5>Component table successfully built
5>Loading File table
5>ISEXP : error : -6225: Resolving Visual Studio .NET project output "Gateway\Gateway.csproj\|Symbols"
5>Express\SingleImage - 1 error(s), 0 warning(s)
5>Log file has been created:
========== Build: 2 succeeded, 1 failed, 1 up-to-date, 2 skipped ==========
0 Kudos
(3) Replies
Level 7


Can you please let us know if you are adding any content files to the VS project? Also, can you kindly share with us the command line you are using to build this project in VS?

Thanks ~ Swetha
0 Kudos
Level 3

Hi and thanks for you reply!

Yes I am adding content files to the VS project. No matter what output I add from the project - Content Files, Debug Symbols etc - it fails to build.

This is the command line I use: SolutionName.sln /rebuild "Release|Any CPU"

What I have found now is that I can successfully build the solution from the command line by using msbuild like this: msbuild.exe SolutionName.sln /property:Configuration=Release /property:Platform="Any CPU"

So the solution (or workaround) would be to use msbuild rather than

Still, it would be nice if would work.

0 Kudos
Level 7 Flexeran
Level 7 Flexeran


This issue seems to be a project specific, I tried to replicate the issue but not successful, have you tried any other projects to build using devenv.exe?

0 Kudos