cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Bug: .NET 4.5 Prerequisite is skipped on Vista

I have an InstallShield project with a single prerequisite: .NET Framework 4.5. It work as expected when installing on Windows 7 (installing the framework) and Windows 8 (not installing it because it's already there), but when testing on Windows Vista, the prerequisite is ignored. My application gets installed, but not .NET 4.5. When I run the application, it fails to launch stating that I need the correct version of .NET.

I have tested this on clean installations of both Windows Vista Business, with SP1 and SP2. I have tried both the "Microsoft .NET Framework 4.5 Full" and "Microsoft .NET Framework 4.5 Web" prerequisites. Both with the same result. The "Microsoft .NET Framework 4.5.1 Web" prerequisite, however, correctly installs the .NET Framework. We only need 4.5 and don't want to force users with 4.5 to install 4.5.1, though.

Flexera, can you confirm that this is a bug and release a fix?
Labels (1)
0 Kudos
1 Reply
Highlighted
Flexera
Flexera

Re: Bug: .NET 4.5 Prerequisite is skipped on Vista

The .NET 4.5 prerequisites do not contain conditions to trigger the install on Vista. You can open the PRQ in notepad and manually add a condition for Vista, however it would be easier to upgrade to Professional or Premier to gain access to the Prerequisite Editor (http://helpnet.flexerasoftware.com/installshield21helplib/installshield21helplib.htm#StartTopic=help...) so that you can add support Vista from the drop down menu.
0 Kudos