cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
palanisamy
Level 7

Arabic Language Support

My projectType is InstallScriptMSI Project..

I want to support Arabic language, Arabic language support included from menu Tool-> Add New Language

I build the Installscript MSI project it throws the following error

ISDEV : error -7132: An error occurred streaming ISSetup.dll support file C:\ProgramFiles\InstallShield\2010\Redist\Language Independent\i386\_isres_0x0401.dll

The File _isres_0x0401.dll not exists in the path mention above, where i get the file?..
Labels (1)
0 Kudos
5 Replies
Marwan
Level 7

The New Language Wizard generates this file when you add a new language. Click on the Help button of the New Language Wizard as there's information in the help library on what is needed to support a new language in Installscript. As a workaround, you can simply make a copy of _isres_0x0409.dll and call it _isres_0x0401.dll
Also, you have to modify all the resources to enable RTL and translate all the strings.
0 Kudos
palanisamy
Level 7

Hi,

I translated English text to Arabic text in string table and _isres_0x0401.dll file , I try to install the product in Arabic OS machine, But initialization dialog is displayed as ??????? mark symbol.

In release Build tab : Build UTF-8 Database set as yes
0 Kudos
Marwan
Level 7

Are you running on XP? Make sure you install the proper Code Pages from Control Panel | Regional And Language Options | Advanced | Code page conversion tables first.
0 Kudos
palanisamy
Level 7

Thanks marwan,
We have Arabic Windows 2008 OS Server Machine, I tried in WindowsXP machine also with Arabic Language pack installed (Control Panel | Regional And Language Options | Advanced | Code page conversion tables first.),
the same issue persist.
0 Kudos
palanisamy
Level 7

In InstallScriptMSI project, Text displayed in Japanese build also as Question mark(??????????) in Setup Inititalizatain dialog and all other dialog, the language pack are properly installed in testing machine.

Please confirm whether it is an Installshield 2010 bug or Japanese not support InstallScriptMSI project.
0 Kudos