cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
dbuccier
Pilgrim

Application dependencies deleted after upgrade installation

My team has been using InstallShield to deploy an in-house desktop C# tool to our developers for the last year or so. However, we recently attempted to make a *very minor* change to our code and redeploy with a new version (changing 2.1 to 2.1.1). When our users attempt to install the new version over the old version apparently the installation deletes files after completion. I have actually watched the installation directory, and it updates the files to the new versions and then deletes several of the files.

Basically our code change to the application was a 1-line change to a constant value and we updated the assembly version of the main exe project from 2.1 to 2.1.1. Then we went into our InstallShield project and updated the product version number to 2.1.1 and generated a new product code. We updated our single upgrade path to include a max version of 2.1.1. Then we rebuilt the solution and created our setup.exe file as a singleimage release type. We are using InstallShield LE in Visual Studio 2012 (and we've also tried in VS 2013). We have never used the RemoveFiles option and I've verified that this table is empty in our isl file.

Uninstalling version 2.1 and then installing 2.1.1 works just fine. The problem only arises when we attempt to upgrade the version. Furthermore, moving the installation location to another folder also works. I'm completely stumped with this issue and really need some help. I have tried a very large number of solutions and done a ton of research online but have found nothing so far.
0 Kudos
6 Replies
Highlighted
dbuccier
Pilgrim

More context

To provide more context to this:

Our solution consists of 5 projects. Three of these are Class Libraries (A, B, C), one is a Windows applicaton (E), and the other is an InstallShield project (I). The application depends on the 3 class libraries and the installshield project depends on all of them. One of the libraries (A) has references to 2 3rd party dll's (X and Y). The files that are being deleted at the end of installation are X, Y and B. Note that renaming the assembly output of B, will cause it to no longer be deleted after installation, but X and Y are still deleted.
0 Kudos
Chaitra
Pilgrim

Re: Application dependencies deleted after upgrade installation

Hi,

As this is a minor upgrade, you need not change the product code and only the minor version number has to be changed and not the build number.

Could you please provide me with your log file? So, that I can investigate the issue further.

Thanks,
Chaitra
0 Kudos
Highlighted
dbuccier
Pilgrim

Re: Application dependencies deleted after upgrade installation

Chaitra wrote:


As this is a minor upgrade, you need not change the product code and only the minor version number has to be changed and not the build number.



So while I call it a minor upgrade, I am requiring my users to uninstall the old version and re-install the new one. The actual output of the executable is being changed. Essentially the connection string to one of the database servers I am accessing has changed, and so the code had to be updated to reflect this. Maybe I shouldn't be labelling this as a minor change, but I don't know how they could install this new version without uninstalling and re-installing. Maybe I could use more information on how I could have users update the files without having to uninstall. Right now I'm redistributing a new setup.exe file that they must run to install the new version. Not changing the product code would mean that the user would be forced to uninstall before attempting to re-install which would not be okay, I need the installer to do that for them.

More to the point, I even tried making this a MAJOR update (updated to version 3.0, changed the product code) and I was still getting the issue where files were deleted. Even if I labelled the type of change incorrectly, the files are still being deleted when they shouldn't be and that is quite bothersome.



Chaitra wrote:

Could you please provide me with your log file? So, that I can investigate the issue further.

I'm not exactly sure what log file you're referring to. Are you talking about the log file produced from running the setup.exe on a machine? From my investigations, this seems almost completely useless. I have attached this log file. Let me know if there's a different one that you'd like though. I appreciate your help!

0 Kudos
Highlighted
dbuccier
Pilgrim

Re: Application dependencies deleted after upgrade installation

Is there anyone who might be able to provide help with this issue? We're essentially about to switch to a different installer if we can't find a way to resolve this.
0 Kudos
Highlighted
jcoone
Pilgrim

Re: Application dependencies deleted after upgrade installation

you may want to post the MSI installation log, but it looks like the events are firing out of sequence.

you mentioned renaming some outputs, do mean you renamed the EXE, or DLLs output by the VS projects when built?

I have most commonly seen this issue when the primary key file for the installation is renamed, in that case the only fix we have ever found for it is to create a new installer project using the same upgrade code as the existing one and including an upgrade path for previous versions.
0 Kudos
Highlighted
dbuccier
Pilgrim

Re: Application dependencies deleted after upgrade installation

jcoone wrote:
the only fix we have ever found for it is to create a new installer project using the same upgrade code as the existing one and including an upgrade path for previous versions.


After some testing it seems as though remaking the installer project fixed the issues we were running into. I'll follow up on this thread if we run into the issue again in the future, but for now this workaround seems to have resolved our issue.
0 Kudos