cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
OTUser
Level 2

Application Mappings Issue with IIS 6.0 and IIS 7.5

Hi,

I am creating a installer for a webapp(service), which creates virtual applications and adds application mappings for the same in IIS.

Issue is that this installer should work for both IIS 6.0 and IIS 7.5.

In IIS 6.0 the Application mappings are referred to without the wildcard.
So if I want dlls to be mapped to a ISAPI.dll, in IIS 6.0 the extension has to be added as '.dll ' (without the quotes), but for IIS 7.5 it has to be added as '*.dll' (without the quotes)

Can I change the extension from within the InstallScript code, or is there any easy way out of this, which I have totally missed?

I am using Installshield 2011.

Thanks for any help provided.

Regards,
OTUser
Labels (1)
0 Kudos
1 Reply
EvanBarr
Level 3

I'm surprised such a clear issue as this has gone unanswered. Since I am having this same issue and may have a work-around, I will respond.

It appears that adding two entries will work, one with the asterisk and one without. IIS7+ will ignore the entry without the asterisk since no file will ever match. I have not yet verified what IIS6 does for entries with the asterisk but I think I remember accidently entering it that way when I was first learning IIS6 and it didn't do anything.

EDIT:
You can't enter with an asterisk into IIS6 manually, and trying it with a script produces an error. So I would guess that this will fail if you try to do this with InstallShield. I am using 2012Spring and they still have not added the ability to put a condition on an Application Mapping. Silly Flexera for not learning the products you try to support.
0 Kudos