cancel
Showing results for 
Search instead for 
Did you mean: 
Ken_Alverson
Pilgrim

After updating to 2015 SP2 - having a file issue

My project is building and installing an older messages_en_US.properties file even though the IDE shows the file with the correct modification date/time. The contents and date modification values match an older file that is under source control, but was replaced with a newer one. I don't know how the project is still being built with the older file when only the newer file is available on the hard drive and shows up correctly in the IDE. I've deleted all the intermediate files before building. And the uninstall does not leave the old file out there either. How can it still be in a new build? All the other files in the same folder are being built correctly. Can someone suggest what might be wrong here?
Labels (1)
0 Kudos
2 Replies
Highlighted
Ken_Alverson
Pilgrim

Re: After updating to 2015 SP2 - having a file issue

I found the issue and it is my fault. I had a custom action unzipping a file which overwrote the installed file with an older file contained inside the zip file. Ops, I removed the custom action since I've since went to using a wrapped version of launch4j instead of using the zip file to contain the objects.
0 Kudos
Ken_Alverson
Pilgrim

Another note of warning for service pack 2 - error on digital signing

Just a note of warning about updating InstallShield 2015 IDE. A couple of days ago, I updated my InstallShield 2015 premier IDE with service pack 2. It turns out when you do that you also have to update any build machines with the standalone install for service pack 2 as well. Our build engineer looked into an issue that popped up on our Jenkins build server; he compared two MSI project files, one that worked for digital signing and the newer one that did not. He found that after updating the IDE to service pack 2, a new parameter "?auto" is appended to the path to the certificate to use for signing. After updating the Jenkins build server with the standalone service pack 2, the standalone build started working again on the project file with the newly added parameter.
0 Kudos