cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Active participant

Advanced UI : "Set Active Page" to "Installation Progress" makes the install to stuck in "Initializing"

Jump to solution

Dear all,

InstallShield 2014 > Advanced UI project > InstallationFeatures Wizard > Install button

In the "InstallationFeatures Wizard" I have set a script  action to the Install button which will test if the selected features combination is valid or not.(ValidateFeatureSelection).

The above function sets the IS_VALID_INPUT property via the script.

Next actions are:

1. Show Secondary Window  IS_VALID_INPUT not equal to True

2. Set Active Page to InstallationFeatures if IS_VALID_INPUT not equal to True

3. Set Active Page to InstallationProgress if IS_VALID_INPUT equal to True

Steps 1-3 are working correctly however when I enter the InstallationProgress  windows the install is stuck in "Initializing" and does not progress.

The log shows function ended successfully and shows the window entering info.

What could be the problem? Could it be that the information about the selected features are lost when I set "Set Active Window" to "InstallationProgress"?

 

Thank you.

Angela

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Active participant

Re: Advanced UI : "Set Active Page" to "Installation Progress" makes the install to stuck in "Initializing"

Jump to solution

Hi angela,

 

I would recommend to put install instead of set active page,

 

Vishalsa_0-1580744304673.png

 

View solution in original post

0 Kudos
4 Replies
Highlighted
Active participant

Re: Advanced UI : "Set Active Page" to "Installation Progress" makes the install to stuck in "Initializing"

Jump to solution

HI Angela,

i) Enable Install button option (Navigation) as "YES"  in before installationprogress dialog.

ii) Enable the debug log and check the action state.

Thanks,

Thananjeyan

0 Kudos
Highlighted
Active participant

Re: Advanced UI : "Set Active Page" to "Installation Progress" makes the install to stuck in "Initializing"

Jump to solution
Hello Thananjeyan_M,
1. Install button is enabled
2. Action state is success (0)
Thank you.
0 Kudos
Highlighted
Active participant

Re: Advanced UI : "Set Active Page" to "Installation Progress" makes the install to stuck in "Initializing"

Jump to solution

Hi angela,

 

I would recommend to put install instead of set active page,

 

Vishalsa_0-1580744304673.png

 

View solution in original post

0 Kudos
Highlighted
Active participant

Re: Advanced UI : "Set Active Page" to "Installation Progress" makes the install to stuck in "Initializing"

Jump to solution

Hello Vishalsa,

Thank you.

0 Kudos