cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mitutoyo
Level 4

Accelerator key definition not visible

I have an InstallScript project and am using the AskOptions dialog in several instances. I have defined accelerators into my options, but they do not display in the dialogs when run (characters are not underlined). The accelerators function properly, but nobody is going to know what they are if they aren't visible.

Is this a known bug in 2010, or is there some other setting needed to display them?
Labels (1)
0 Kudos
2 Replies
Marwan
Level 7

This a Windows XP+ feature (most users are familiar with this).
Accelerators, by default, get the underscores only when alt key is pressed. I am not aware of any setting you can change as to always show underscores.
0 Kudos
mitutoyo
Level 4

Thanks for the quick response. Your description is clear, however, I'm struggling with a disconnect between the description of how the accelerators work (see the AskOptions page, szText1 section in your help files). As I have re-read the page, it does make clear the accelerators are defined in a way that make them functional when the ALT button is pressed. In fact, the accelerators function perfectly without pressing Alt, only the "hotkey" character needs to be pressed. So it appears the Alt key is necessary only for underlining the appropriate character that is the acclerator. Perhaps it would be a good idea to modify the help file text to define this more clearly.
0 Kudos