cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dtmansy
Level 2

uninstall deletes user created files

I am using IA 2008 VP1 EE and creating an installer/uninstaller to be used
on Linux (RHEL4). Installation works fine. The installed application creates
some files (log files, trace files, database files, etc). The documentation
says that uninstall is not supposed to remove user created files or other
files that were not part of the original installation, but, when I run the
uninstaller it removes everything!

These user created files are created under folders that ARE part of the
installation. But I wouldn't think that should matter?

I have not modified any of the defaults on the Install tab (for example
I have not checked the box to recursively delete contents of a folder
or anything). I've tried removing the Uninstall action in the Install tab,
saving the project, then re-adding it (as was suggested in another forum post)
but this did not resolve the problem.

I tried creating a new simple project that only installs a few files and folders.
I built it and ran the installer. After the installation completed I manually
created some files under the installation directory, then ran the uninstaller.
The uninstaller removed the installed files as well as the files I manually
added after the installation.
Am I configuring something wrong in the IA project or is this a bug?
Labels (1)
0 Kudos
4 Replies
interpaul
Level 3

Are you using speed folders?

I've had problems in the past when I've told the installer to install the folder and the folder contents when using the speed folder. It removes the folder as well (and everything new underneath it) as I guess it did create it.

To get around this I created the folder myself and installed only the speed folder's contents under that folder.
0 Kudos
dtmansy
Level 2

I was using a regular folder, but all of my installed files were under this folder. I removed that folder, added a Create Folder action and added a Speed Folder action to add the contents of the folder (but not the folder itself). This seems to have fixed the problem.
Thanks for the work around!

There seem to be several uninstall bugs here!!! :eek:
0 Kudos
pv7721
Level 20

I suggest you create a thread for each new issue you encounter (easier to follow this way).
0 Kudos
nosrednayduj
Level 7

That's really weird -- but it works. Thanks. My speedfolder has a deep directory structure, so I was surprised that saying "create folder contents" under the created folder kept not just new files in the top level of the speedfolder, but in fact, all new files in the structure below. But it does. Thanks again. You saved me having to write my own code that would copy everything to TEMP and then recopy it back in!
0 Kudos