cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

com.flexera.authenticator did not pass helper check com.flexera.helper

We tried to take build for Catalina with Authentication and code sign while launching application It is starting elevation process and disappears post authentication, we observed following error in console log, what does it mean and how can we fix it. We signed both helper tool and code with same certificate.

smd : com.flexera.authenticator did not pass helper check com.flexera.helper

0 Kudos
7 Replies
Highlighted
Flexera beginner

Re: com.flexera.authenticator did not pass helper check com.flexera.helper

Hi @gokulbontha 

For authenticated mac installer you need to build helper tool first before building actual installer.

Please refer InstallAnywhere help document for building helper tool.

0 Kudos
Highlighted
Flexera beginner

Re: com.flexera.authenticator did not pass helper check com.flexera.helper

Hi @sksuvarna ,

Yes I have followed the same I build helper tool first and then I have taken build.

0 Kudos
Highlighted
Flexera beginner

Re: com.flexera.authenticator did not pass helper check com.flexera.helper

hi @gokulbontha 

when you launch the installer any logs generated under /tmp? something like ia_err**** or ia_out****

if so possible to share that? 

And one more question.. you are building installer on mac itself or building on windows and running it on mac?

0 Kudos
Highlighted
Flexera beginner

Re: com.flexera.authenticator did not pass helper check com.flexera.helper

@sksuvarna 

No logs were generated under /tmp folder or /tmp/ia_tmp

I tried both building the installer on windows (IA 2020 licensed) and MAC 10.15.7 (IA 2020 Trail version)

0 Kudos
Highlighted
Flexera beginner

Re: com.flexera.authenticator did not pass helper check com.flexera.helper

@gokulbontha 

That is strange. we never observed this before.

Could you please share the steps you followed(beginning to end) so that I can recreate the scenario and verify.

0 Kudos
Highlighted
Flexera beginner

Re: com.flexera.authenticator did not pass helper check com.flexera.helper

Hi @sksuvarna ,

Steps :

1) Open new IA 2020 project
2) Update the Mac OS X platform section with following details

a) Authentication - Yes
b) Always show GUI - yes
c) Permissions - 777
d) Code Sign - provide certificate path and keystore password

3) Prepare helper tool

a) Choose Path to the OS X SDK (I have selected MacOXX11.0.sdk from my xcode)
b) Select certificate from my keychain

4) Now take build for Mac OS X section, I have removed other build targets as those are not required for me.
5) Verify the code sign for the build and helper.
6) My installer is ready which doesn't working

NOTE : We are using Apple developer certificate that is generated from xcode application and that is not subscribed for Apple developer program.

0 Kudos
Highlighted
Flexera beginner

Re: com.flexera.authenticator did not pass helper check com.flexera.helper

@sksuvarna Did you get a chance to reproduce the issue ?

0 Kudos