Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

Uninstall.exe Error: installer User interface mode not supported

Hi Everyone,

Am actually new to InstallAnyWhere, am facing bit weird problem during un-installating our product which was developed using installanywhere2013,

The Steps which resulted this error:

1. Initially Performed a fresh installation of our product.
2. And then on top of it, performed an upgrade process and the installation went fine.
3. Then I've tried to Uninstall our product, then it poping-up the error message saying "installer User interface mode not supported"

I've tried to google for solution, but most of the results I've got were actually when people are trying to install the product but not when running the Uninstall.exe.

Solutions I've Tried but didn't work for me:

1. Using Command Line ran the Uninstaller using arguments -i GUI, -i CONSOLE
2. Tried to Change the TEMP & TMP path in Environment Variables.
3. In Uninstall.exe properties, Under Compatibility tab tried to select Windows7 and ran the Un-installer.
4. Tried to run the Un-install.exe as administrator.

I request anyone to help in sorting out the issue.
Labels (1)
0 Kudos
(2) Replies
Level 4

Solution:This is actually a "bug" in InstallAnyWhere 2013 & 2015 am not sure about previous versions, the reason for the issue is ".com.zerog.registry.xml" file which is created by "Create Uninstall Action" which holds most of the installation information. The Un-installer.exe make use of same file during Un-installation process, but the Major problem is the Un-installer expects the ".com.zerog.registry.xml" to less than 10KB, if it exceeds that limit it will throw the Error.

During Upgrade: If the same file already exceeded the 10KB limit, when upgrading the product then the installation just stops at 11% and doesn't go ahead in installing the components.
0 Kudos
Level 4

Its actually a "Bug" in InstallAnyWhere 2013 & 2015 version, it was confirmed by Flexera Team
0 Kudos