cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
mjspka
Pilgrim

The installer is failing with libjvm.so: cannot restore segment prot after reloc: Per

1. I had a project in InstallAnywhere 2011 SP3 with vm option.
2. When I build the project it had created install.bin
3) Now I had copied the install.bin to Redhat linux machine where SELINUX is enabled with enforcing
4) When I ran ./install.bin in GUI mode, the launcher blew away with the error "dl failure on line 875".
5) I have a check in my installer to gracefully terminate the installer with a panel saying SELINUX is enabled and thus would not want to have launcher to be killed.
6) The problem is when I bundle Java 1.7 with the installer. If I bundle java 1.6 then there is no problem.


*******************************************************
Here is the output of

$ ./install.bin


Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

Error: dl failure on line 875
Error: failed /tmp/install.dir.6440/Linux/resource/jre/lib/i386/server/libjvm.so, because /tmp/install.dir.6440/Linux/resource/jre/lib/i386/server/libjvm.so: cannot restore segment prot after reloc: Permission denied


*******************************************************
The log from /var/log/audit/audit.log is

type=AVC msg=audit(1359067084.881:2455): avc: denied { execmod } for pid=6873 comm="java" path="/tmp/install.dir.6873/Linux/resource/jre/lib/i386/server/libjvm.so" dev=dm-0 ino=66317 scontext=root:system_r:initrc_t:s0-s0:c0.c1023 tcontext=rootSmiley Surprisedbject_r:initrc_tmp_t:s0 tclass=file
type=SYSCALL msg=audit(1359067084.881:2455): arch=40000003 syscall=125 success=no exit=-13 a0=f7310000 a1=76e000 a2=5 a3=ffe0a5c0 items=0 ppid=6672 pid=6873 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=1 comm="java" exe="/tmp/install.dir.6873/Linux/resource/jre/bin/java" subj=root:system_r:initrc_t:s0-s0:c0.c1023 key=(null)

*******************************************************


Any Ideas????
Labels (1)
0 Kudos
1 Reply
srknitw
Flexera beginner

I am also facing same problem.

Did you find any solution? Please let me know.
0 Kudos