Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Java null pointer exception with uninstaller

We use Installanywhere 2009 enterprise edition to create installers for our software. I include the Java VM as part of the installer (JRE 1.6).The installer works and installs everything fine. But when the uninstaller is invoked, it pops up a window with the following message

ERROR: java.lang.NullPointer Exception

The pop-up window title is "WJView Error".

After I click "OK", the uninstallation continues and completes ok.

We did not have this issue with 2008 enterprise edition of the installanywhere.

Is this a known issue in IA 2009? Is there something in my config/project that is not right?
Labels (1)
0 Kudos
(3) Replies
Level 3

I upgraded 2 installers from IA 7 to IA 2009

I too, am now using the default bundled JRE that ships with 2009, that is the 1.6 JRE on the windows platform.

And, I am seeing the same exact behavior when I click to run my uninstaller on both of them.

I submitted a support incident.
0 Kudos
Level 3

Support said the following:

Thank you for contacting Acresso Technical Support. I understand that a null pointer exception is thrown, when you are trying to run the uninstaller. I suggest that you refer to the kb link that is mentioned below, which provides the information regarding the common uninstaller problems: I hope this information helps you. Please let me know, if I can be of further assistance. Regards Sony Technical Support Engineer Acresso Software Please click this link: to review the incident details. Regards, Acresso Support

They didn't say "Yet" that doing this will make the null ptr problem go away yet.
0 Kudos
Level 3

As indicated I filed a support case. They said, read this KB article. Which I did read. Unfortunately, I had an issue following the directions. You see my "create uninstaller action" was inside a "uninstaller folder". So, I started by removing the "uninstaller folder" and then tried to recreate everything.

When I created the "Create Uninstaller Action", it wouldn't go into the "uninstaller folder". It was created at the same level in the hierarchy.

So, my guess at the time, was oh no, I will need to recreate everything from scratch, the disk layout etc... and I didn't want to do that. So, I logged another message with support looking for help. It was:

Sony, I read the referenced KB article. It is effectively asking me to remove my Uninstaller, and then re-create it.

I started to go through this work last night and this morning. The first thing I did was make screen captures, of the different actions in my "Install" step, that were germain to the uninstaller.

For instance, in my Install Step, we have a create Folder Action, where we create a folder called uninstall_mn

then, within that folder, we have:
1) the create Installer Action
2) Add File Action
3) Add File Action

Seems simple enough.

So today, I first tried to delete the Create Folder Action, and its contents and then recreate it. I was able to recreate the Create Folder Action, but I was not able to create my uninstaller inside this folder, like I previously had.

So, I reverted back to my saved copy of the project.
I then, simply deleted the "Create Uninstaller" action from within the Folder, and I attempted to recreate it. So I did an add action Create Uninstaller - but this did not get put into my folder.

I have some screen shots of the way the project was structured, that I will add to this support case.

I would be glad to talk to someone about this perhaps on the phone.

Does anyone know for a fact that If I recreate my uninstaller, that this WJView Error will go away, or have I been sent down some step to simply try this ?

I really wish we focused on this communication.

Today, I tried this again.
Only this time, I simply deleted the "Create Uninstaller Action".
I did it as follows:
1) Grabbed Screen shots of the action and each of the rules, so I could recreate it exactly

2) And then I saved the file
3) then closed IA
4) I then openned IA
5) I loaded the project
6) I then put my cursor, within the "uninstaller folder, on the "Add file Action"
7) I then added the action, "Create Uninstaller Action"

This time, it got added inside my unistaller folder.
Previously, when I tried this, I had removed my whole uninstaller folder, so it
was now empty. I then was unable to create my uninstaller inside the uninstaller folder. It got created at the same level in the hierarchy as the uninstaller folder.
So I stopped.

I believe, I could have Created the uninstaller folder, and then "Added a file action" to it. My bet is that if my Uninstall folder had at least one thing in it, then I would have been able to create the Uninstaller Action in the folder.

I would suggest you have someone look into this - this may be a bug in your software.

Having said all of that, today I deleted my Create Uninstall Action, and then recreated it.

I then was able to not only install my product but I could uninstall it also w/o getting the WJView Error Panel.

So I then went did the same thing to my other product.

So the bottom line is:
IA has a problem. A WJVIew Error Panel does get popped up by IA when clicking on an uninstaller. If you delete the Create Uninstaller Action and recreated it (of course saving the file inbetween), the IA problem will go away.

Best Regards,
0 Kudos