cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

InstallAnywhere can't run CScript on 64bit Windows.

I have a VBScript foo.vbs which uses Telnet to execute some commands on a remote system.

I then create a foo.wsf file to execute it.

I used Execute Script/Batch File in InstallAnywhere to run the VBScript as follows:

cscript foo.wsf

It worked like charm on 32bit Windows, however, on 64bit Windows, it didn't even get executed at all.

Thanks very much for your help.
Labels (1)
0 Kudos
2 Replies
Highlighted
Flexera beginner

Re: InstallAnywhere can't run CScript on 64bit Windows.

Strange, can you verify that you do not have any rule or tag that may prevent the script to be ran on that 64 bit host?

Also adding cscript without argument is useless (AFAIK), you can simply put the script name in the action "foo.wsf".

You should set debug traces if it still does not help.
Also you can access the script from temp location (INSTALLER_TEMP_DIR) (if exists) and try to execute it manually.

my 2 cents...

--Jerome
0 Kudos
Highlighted
Pilgrim

Re: InstallAnywhere can't run CScript on 64bit Windows.

Yes, foo.wsf has foo.vbs attached to it.

If I run it on the command line, it works.

I found out later that the problem is with Telnet since there is no 32bit Telnet on Windows 64bit machine. Sigh.

Any more ideas.

Thanks.

jerome_IA wrote:
Strange, can you verify that you do not have any rule or tag that may prevent the script to be ran on that 64 bit host?

Also adding cscript without argument is useless (AFAIK), you can simply put the script name in the action "foo.wsf".

You should set debug traces if it still does not help.
Also you can access the script from temp location (INSTALLER_TEMP_DIR) (if exists) and try to execute it manually.

my 2 cents...

--Jerome
0 Kudos