cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
jerome_l
Flexera beginner

Evaluation Of InstallAnywhere 2020

Hi,

As I do not have any valid support contract, I'll post my finding there.

I just downloaded InstallAnywhere 2020 for evaluation, but my built linux installer cannot be launched:

 

install.bin: 3579: //Fix: not found
install.bin: 3580: //: Permission denied

Launching installer...

JRE libraries are missing or not compatible....
Exiting....

 

By checking the generated installer, some comment lines are starting with / instead of # ... fail

# Checking Java Version and adding Java-9 module illegal access switch only in case of Java-9 and above.
# Chances are this options may be removed in the next major release.

debugOut "Using VM version -> $usingVmVersion"
extractVMVer=`echo $usingVmVersion | cut -c1-2`
if [ "$extractVMVer" != "1." ] ; then
debugOut "Java 9 or higher version detected. Adding module access switch."

isJava9AndAbove="TRUE"
//Fix for WO IA-20048 Adding JVM param to disable default uiScaling
// of Java 9 and above
java9Options="--add-opens java.base/jdk.internal.loader=ALL-UNNAMED -Dsun.java2d.uiScale.enabled=false "
options="$java9Options $options"
fi

 

I then tried altering the file (replacing / with #), but it is then seen as corrupted...

Let's hope there will be fix soon ...

 

0 Kudos
1 Reply
jerome_l
Flexera beginner

Re: Evaluation Of InstallAnywhere 2020

Just to clarify, the incorrect comments are unrelated to the crash ... I mistakenly selected an incorrect java version.

So error seen with "//" has no other effect than printing errors in console.

0 Kudos