jrbowen
Pilgrim

Crash on Windows 2008

I have a simple installer that includes a 1.6 VM and some custom rules. It runs fine on Windows XP or Windows 2003. However, on Windows Server 2008, it crashes immediately after the "preparing to install" phase completes with the following:


Problem signature:
Problem Event Name: APPCRASH
Application Name: install.exe_InstallAnywhere
Application Version: 10.0.0.0
Application Timestamp: 4a3263be
Fault Module Name: ntdll.dll
Fault Module Version: 6.0.6002.18005
Fault Module Timestamp: 49e02d47
Exception Code: c0000008
Exception Offset: 00034ddf
OS Version: 6.0.6002.2.2.0.274.10
Locale ID: 1033
Additional Information 1: 23f4
Additional Information 2: 5695a8586c5e049a4934a8e39001c42b
Additional Information 3: b0ec
Additional Information 4: 7e1f21c4f960ecdabcceb34acaaa3fa3



Does anyone have any idea why this might be happening?
Labels (1)
0 Kudos
7 Replies
pv7721
Flexera beginner

Maybe you could try running the installer in compatibility mode?
0 Kudos
jrbowen
Pilgrim

I've stripped things down to an installer with no content, no custom code, and no embedded VM. This fails in the same way. None of the compatibility modes appear to change this behavior.
0 Kudos
pv7721
Flexera beginner

Looks like the exact same issue as the one here: http://community.acresso.com/showthread.php?t=188102 only different IA version...
0 Kudos
jerome_IA
Flexera beginner

FYI, I posted something in http://community.flexerasoftware.com/showthread.php?t=188102.

The issue seems related to an "eval" version of windows 2008 ... works well on other windoz
0 Kudos
dherren
Pilgrim

Could this same issue affect the eval/beta versions of windows 7? I don't have these available to me or I would test them myself.
0 Kudos
pv7721
Flexera beginner

jerome_IA wrote:
FYI, I posted something in http://community.flexerasoftware.com/showthread.php?t=188102.

The issue seems related to an "eval" version of windows 2008 ... works well on other windoz


AFAIK, a debug version of Windows is NOT the same as an eval version. It is simply a full version of Windows but with some debug symbols activated. Its purpose is to help developers get more accurate information in case of crashes.
0 Kudos
pv7721
Flexera beginner

dherren wrote:
Could this same issue affect the eval/beta versions of windows 7? I don't have these available to me or I would test them myself.


Please see my previous post about the difference between debug and eval versions. With Windows 7 I think that the issue is different. As the Windows 7 was not officially available at the time Windows 2009 SP 1 was released I'm not sure if it is supported or not.
0 Kudos