Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

To find ts location using caprequestutil utility

When I am trying to activate a license using Capability Request Utility, license is getting activated because the count on FNO is getting reduced, but I am not able to find the location of TS.

Is there any default location of TS files?

I have used this command to activate license in my machine:

caprequestutil.bat -idtype ethernet -id IdentityClient.bin -host [MAC_ADDRESS] -name [HOST_NAME] -type [HOST_TYPE] -machine PHYSICAL -activate [ACTIVATION_ID]  http://hostname:8888/flexnet/deviceservices

The default path of TS which is given in Capability request example in the toolkit is "//Documents"

I have checked that location and also tried to configure the ts location using code and checked there also but not a single file is present.

0 Kudos
(3) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @Shivani_209 ,

You may not be able to see Trusted Storage files by default as they are stored as hidden files.  If you are on a Windows system make sure you have "Hidden Items" selected in the File Explorer View-Show/hide menu option: 


Or if you are using a command prompt to view the directory contents you can use the /a:h switch to view hidden files:

C:\Users\jberthold\Documents>dir /a:h
Volume in drive C is OSDisk
Volume Serial Number is 44ED-B996

Directory of C:\Users\jberthold\Documents

05/03/2023 05:08 PM 4,608 mccgwguycfhhjpwgeehnjgfsyfcdnpz
05/03/2023 05:08 PM       87 amjgufjswnphbbfjbpujuyyuheusbdzn



0 Kudos


I am able to get the files in documents folder now.

I have tried to acquire license using CapabilityRequest example which is present in FNE toolkit, So the files getting saved are like this: 


Also I am trying to acquire licence using caprequestutil which is present in tools folder in toolkit. So the files getting saved are like this:


So, the issue is,

The one file with a name starting "amcc....." which is present in both cases, but its size is 5 kb when we try with utility and 6 kb when we try with code.

Now when I am trying to view the license using the view example which is in the toolkit. I am able to view the license which is acquired through code but not which is acquired using utility. The command that I have used is given in an earlier post.

When I am trying to copy and paste that "amcc......." file from another folder, the license can be viewed now.


Why is that file not getting generated correctly using the utility?  




0 Kudos

Hi @Shivani_209 ,

The Capability Request Utility is intended for quick testing and does not use the same trusted storage as do the examples provided in the toolkit.  It is not intended to be used in conjunction with the toolkit examples.


Best regards,


0 Kudos