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Windows Installer Error 2203
Windows Installer Error 2203
Summary
Error -2203: Database: [2]. Cannot open database file. System error [3]Symptoms
When running an installation, the following error may occur:
Error -2203: Database: [2]. Cannot open database file. System error [3]
[2] is a placeholder that contains the path to the database, and [3] is a placeholder that contains the specific error code.
Cause
This is a general error message that is displayed by the Microsoft Windows Installer Service (MSI). It indicates that the file specified in the error could not be opened, and a more specific error code that identifies why it cannot be opened is displayed at the end of the error message.
This error has been known to occur in the following scenarios:
- When a patch is being applied to an existing application over a network connection.
- The Transform Wizard is used to apply an MST file (transform) to an MSI file (main setup) and generate a New MSI file that contains the changes included in the transform. The error has been known to occur during this process in very rare instances.
- The file specified in the error message cannot be found in the location where the setup expects it to be located.
- You do not have sufficient privileges to access the location specified in the error message.
- As this error message is general in nature, this can occur for various other reasons on an intermittent basis.
Resolution
- To resolve this behavior, copy the patch to the local drive and run it from this location. In a few rare instances, there has been problems when applying patches over a network, as the permissions were not fully granted, or another problem existed with the network that resulted in this behavior.
-
If this error occurs after using the Transform Wizard to apply a transform to a package (a base MSI file) to yield a New package, modify the MSI file with the changes included in the MST file to resolve this behavior. For example, if the transform added a feature to the setup, add this feature into the base MSI file, and avoid using the transform altogether. In some rare cases, the database could not be found during this process, and the only resolution was to avoid using an MST file entirely and make the desired modifications to the MSI file directly. Additional information on transforms can be found in the InstallShield Help Library topic Transforms.
- Use the Windows Explorer to browse to the location specified in the error message and make sure the file is present in this location. If it does not exist, move the file to the expected location and run the setup again.
- If you do not have sufficient privileges to access the location where this file resides, this error may occur. Contact your system administrator to make sure you have sufficient permissions to access the path specified in the error message.
- For all other scenarios, reference the error number displayed at the end of the error message. This is a more specific error code and provides additional information on the exact cause of the error.
For example, the error may display as follows:
Error -2203: Database: 'C:\MyTest\MyFile.mst'. Cannot open database file. System error -2147287037
The system error listed can be passed to the InstallScript function FormatMessage to translate this code into meaningful text. In the above example, the following code could be placed into the script:
MessageBox( FormatMessage( -2147287037 ), 0 );
This displays a MessageBox that contains the translated value of this error code. In this example, the MessageBox would read:
'The path %1 could not be found'
This provides some additional information on why this error is occurring and indicates that the file specified in the error message does not exist in the location where the installer expects it to be. This issue could be resolved by moving the file to the expected location and rebuilding the setup.
Note: Some error codes do not have text associated with them, which causes the FormatMessage function to return a blank message. If this is the case, validate your setup to see if any errors exist in your setup that may be causing this error. More information on validating your setup can be found in the InstallShield Help Library topic Validation.
Additional Information
If this behavior occurs and you are using an older version than InstallShield for Windows Installer 1.52, upgrade to at least version 1.52. This issue occurs in older versions more frequently but has been resolved in version 1.52 and later. Visit the InstallShield Product and License Center for information on the latest releases available.
Additional information on the FormatMessage InstallScript function, including sample script, can be found in the InstallShield Help Library topic FormatMessage.
Further information on transforms (MST files) can be found in the InstallShield Help Library topic Applying Transforms.
Related KB Articles
Reference:Install Fails with SECUREREPAIR: Error determining package source type