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Windows Installer Error 1334

Windows Installer Error 1334

Summary

Discussion on the causes and resolution of Windows Installer error -1334.

Symptoms

When running an installation, the following error may occur:

Error -1334: The file [2] cannot be installed because the file cannot be found in the cabinet file [3]. This could indicate a network error, an error reading from the CD-ROM, or a problem with this package.

[2] and [3] are placeholders where information specific to the error appears.


Cause

This is a Microsoft error that might occur in any of the following scenarios:

  1. The previous version of the package that was installed is still cached on the system. This can happen if a new version of the same package (same Product Code and Package Code) is modified and then run without completely uninstalling the old package from the system. For additional information on caching, see the Additional Information section below.

  2. A compressed release has been built incorrectly (for example, there are missing files).
  3. The installation contains dynamic file linking, the "Previous Package" option is used in the Release Wizard to upgrade multiple older versions, and multiple files with the same name are included. These options are not necessarily related, but are known to cause this behavior when used simultaneously.

  4. The value in the Sequence column specifying the sequence of a patch within the specified PatchFamily is not unique.
  5. When/if files are re-sequenced an issue may occur because of how features are associated with a CAB file is determined at build. Each feature in the build is expected to have a first sequence number associated with it. Using previous package syncing may cause these numbers to be off, and during build he wrong feature is used to include CABs and/or files.


Resolution

To resolve this error do the following:

  1. If a previous version of the package is still cached on the system, remove it:

    1. Run the uninstallation of the package on the system if it is still present.

    2. Verify that both uninstall keys are removed from the system by launching the Registry Editor (by typing 'regedit' in the Windows | Run dialog) and checking the following registry keys:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\<PRODUCTCODE>
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_<PRODUCTCODE>

      If you find the keys, manually delete them.

    3. Generate a log of the installation that fails with run-time error 1334.

    4. Find the value of the DATABASE public property in the log file. It should provide the location of the cached MSI package.

    5. Delete the cached package.

    6. In the future, make sure that the package is properly uninstalled using Add/Remove Programs before installing a modified version. In addition, it is highly recommended to not release different versions of the same package without authoring the new version as a major or minor upgrade.

  2. If building a compressed release, use the Release Wizard to build a new release with a new release name. This recreates the release and resolves any errors if the package was incorrectly built initially.

    It also may prove helpful to build the release as uncompressed to verify if this error still occurs. Building as an uncompressed release may be a suitable workaround to this error as well.

  3. If the installation meets all three of the following criteria:

    • The installation uses dynamic file linking.

    • The Previous Package option in the Releases view is being used.

    • Multiple files in the installation have the same name.


    4. Increase the Sequence Number of the Patch using the Tab Sequence on the Patch Configuration. The value in the Sequence column specifies the sequence of a patch within the specified PatchFamily. Change by incrementing the value for the Sequence in the event this Patch includes Supersedence.

    The value is expressed in the format of Version data. The value contains between 1 and 4 fields and each field has a range of 0 to 65535. Members of PatchFamily are sorted and applied to the target product in the order of increasing Sequence values. For example, the following six values are increasing: 1, 1.1, 1.2, 2.01, 2.01.1, 2.01.1.1.

    5. Number of suggestions for re-sequenced files in CABs:

    (A) First workaround for this issue is to avoid using the Previous Package setting on the Build tab of the Release.

    (B) Turn off/disable file sequence syncing by including an undocumented property DoNotSyncSequenceNumbers to the InstallShield table. Use the Direct Editor to access the table, add the property and provide it with the value 1. This should yield the expected results and avoid the runtime 1334 error.



    For additional information reference: MsiPatchSequence Table


Additional Information

Caching

Microsoft uses caching to store a backup copy of an MSI package on the target machine. This backup copy is used during maintenance mode, when repairing or modifying the existing installation. Without this cached copy, the setup prompts for the original media each time maintenance mode is used. By default, Microsoft randomly renames the MSI package and places it in the following hidden location:

<WINDOWSFOLDER>\Installer

For example, on a Windows 2000 machine, this location is:

C:\WINNT\Installer

This error is briefly documented in the MSI Help Library topic Windows Installer Error Messages.

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Version history
Last update:
‎Dec 05, 2007 06:12 PM
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