This website uses cookies. By clicking Accept, you consent to the use of cookies. Click Here to learn more about how we use cookies.
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
- Revenera Community
- :
- InstallShield
- :
- InstallShield Knowledge Base
- :
- Upgrade Error: A Newer Version of This Application is Already Installed on This Computer
Subscribe
- Mark as New
- Mark as Read
- Subscribe
- Printer Friendly Page
- Report Inappropriate Content
Upgrade Error: A Newer Version of This Application is Already Installed on This Computer
Upgrade Error: A Newer Version of This Application is Already Installed on This Computer
Summary
Upgrade Error: A newer version of this application is already installed on this computer.Symptoms
During a major upgrade installation, the following error message may be displayed:A newer version of this application is already installed on this computer. If you wish to install this version, please uninstall the newer version first. Click OK to exit the wizard.
Cause
This error has been known to occur when the product version of the ISPreventDowngrade item is not set correctly.Example: The Product Version is set to: Any earlier version
Resolution
By default, each project includes an ISPreventDowngrade major upgrade item, which enables you to prevent end users from being able to install the current version of your product over a future major version of the same product.To resolve this error message, set the Product Version of the ISPreventDowngrade item within a specific range of versions as follows:
1. Expand the Media folder.
2. Click Upgrades.
3. Expand the Upgrade Windows Installer Setup option.
4. Click the ISPreventDowngrade item.
5. In the Product Version section, select the option: Within a specific range of versions: (Minimum Version ? Maximum Version)
6. In the Minimum Version field, enter the product version number of the current project that includes your major upgrade item. The Maximum Version field can be NULL.
Additional Information
For more information about the ISPreventDowngrade support, take a look at the InstallShield Help Library topic: Preventing the Current Installation from Overwriting a Future Major Version of the Same Product
No ratings