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Build Error 6259

Build Error 6259

Summary

Error -6259: Internal build error.

Symptoms

When you are building an InstallShield project, the following error may occur:

Error -6259: Internal build error.

Cause

This error is known to occur for the following reasons:

  1. The digital signature password provided in the Release Wizard is incorrect.
  2. One or more of the digital signature files is missing.
  3. The digital signature files have expired and are, therefore, invalid. Digital signatures are only valid for a limited time and can cause this error when expired.
  4. The digital signature syntax entered into the Release Wizard is incorrect.
  5. When building from the command-line utility, IsSaBld.exe, on a standalone build machine, and the file signtool.exe is not present on the build machine.

Resolution

  1. Verify the password entered for the digital signature in the Digital Signature panel of the Release Wizard is accurate. Note this password is case sensitive. If in doubt, contact the digital signature issuer, such as VeriSign, for the correct password.

    Another way to verify that the password is accurate is to manual calling the utility signtool.exe to sign a file. This file is located, by default, in <ProductPath>\Support. Additional information on the command-line parameters to pass to digitally sign a file can be found in the Using the Netscape Object Signing Tool article. If the signing process fails using this method as well, it is safe to assume that the password is incorrect.

  2. Verify that .spc and .pvk files were entered for the digital signature in the Digital Signature panel of the Release Wizard.

  3. If the digital signature has expired, contact the digital signature issuer, such as VeriSign, to purchase a new digital signature.

    Another option to determine if the password is expired can be found in Resolution A. The signtool.exe utility can be used to manually sign a file to ensure it works correctly. This would easily determine if the problem is caused by an expired or incorrect password or for some other reason.

  4. The information entered in the Digital Signature panel of the Release Wizard must be accurate for the signing to complete properly. Make sure the URL specified is accurate, and the .spc and .pvk files specified are located in the path indicated.

  5. Search for the file signcode.exe in the <PROGRAMFILES>\InstallShield\StandaloneBuild directory. If this is not present, manually copy it to this location from one of the following sources:
    • A machine that has the full version of InstallShield DevStudio or Developer installed. This file can be found in the following location: <ProductPath>\System.
    • The InstallShield CD. Perform a search in Windows to locate this file on the CD itself.

Note: Examples of <ProductPath> may be C:\Program Files\InstallShield\AdminStudio\5.5\DevStudio or C:\Program Files\installShield\DevStudio


Additional Information

Further details may be found at the VeriSign Web site.

Additional information on digital signing can be found in the Help Library topic Digital Signing and Security.

This error is briefly documented in the Help Library topic Build Errors and Warnings.

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Version history
Last update:
‎Dec 05, 2007 06:11 PM
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