Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

"Error 27504" when installing against SQL 2012 SP2

During an install, I call the SQLRTTestConnection2 to make sure the user has entered valid SQL connection settings.

This method works against SQL 2012 SP1, but after an upgrade to SQL 2012 SP2 (including a hotfix), the call fails with "Error 27504. SQL version requirements not met: (local). This installation requires Microsoft SQL Server 9.00.1399 or later."

This issue was reported by one of our customers and I was able to replicate it on my pc - Windows 7 Professional SP1, 64-bit operating system. After the SQL upgrade, the SQL version was set to 11.0.5623

I've installed a demo version of Installshield 2015 this morning and upgraded one of my Installshield MSI projects. Unfortunately, the same error occured.

I eventually discovered what was causing this issue; my projects's "SQL Scripts" settings have a requirement defined againts "Microsoft SQL Server" of "SQL Server 2005 RTM (Release to Manufacturing)". If I remove this setting the setup runs without any issues.

I assume this error needs to be logged?

PS I've also added this thread under Installshield 2012 (
Labels (1)
0 Kudos
(6) Replies
Level 17

It turned out that the system and build information for the current installation of SQL Server returned by the @@version scalar function contains an additional information highlighted in red below, and therefore InstallShield is unable to determine the product version (11.0.5623.0) from the string correctly:

Microsoft SQL Server 2012 (SP2-CU7) (KB3072100) - 11.0.5623.0 (Intel X86)

To get it workaround, you can change InstallShield to use the SERVERPROPERTY metadata function by following the steps below:

  • Open your InstallShield project.
  • Go to the Direct Editor and select the ISSQLDBMetaData table.
  • Find the MSSQLServer entry.
  • Change the value of the VersionInfoCmd column to SELECT SERVERPROPERTY('ProductVersion')
  • Remove the value from the VersionBeginToken and VersionEndToken column.
  • Save the changes and rebuild your project.

    This issue has been filed under #IOJ-1741080 and it will be fixed in a future version of InstallShield. Thank you for reporting this.
  • 0 Kudos
    Level 13

    Is there a hotfix available to fix this for IS 2015 SP1?
    0 Kudos
    Level 5

    Are there any plans to fix this issue in existing versions of InstallShield? 2014? 2015? 2016?
    0 Kudos
    Level 17

    This issue has been fixed in InstallShield 2016. In InstallShield 2015 SP1 and previous versions of InstallShield, you can get it workaround by following the steps posted earlier in this thread.
    0 Kudos
    Level 2

    Hi team,

    In our client's machine, while installing against sql 2014(version-12.0.5203.0), we encountered error -" 27504. sql version requirements not met:(local) this installation requires Microsoft sql server 9.00.2047 or later"

    I tried to follow the workaround steps which is given in this discussion thread
    Open the InstallShield project.
    Go to the Direct Editor and select the ISSQLDBMetaData table.

    But when i went to Direct Editor and select the ISSQLDBMetaData table, i dont find any MSSQLServer entry.
    Please let me know what should be my next steps?

    0 Kudos
    Level 3

    InstallShield is unable to determine the product version from the string correctly.
    0 Kudos