Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 6

With a deleted feature, updating causes installshield to be broken

InstallScript project - windows 7, 64bit

Our new version of software have removed one of the features. During an update, we call FeatureRemoveAllInLogOnly() per Flexera. Basically this is the only change for the new version, so the software being installed has not changed (only the version number, no files or file content changed).

After updating from the previous version, the install program no longer works and bad messages are shown to the user.

The first indication that something is wrong is that installshield requests that you reboot after updating, which should not be needed.

When you do reboot, after logging in and before you are brought the windows screen you get the attached error (setuperror.png) 2 times. You can press OK to both and windows finishes logging in. Also note that the software actually runs properly.

The problem is that you can no longer invoke the install program from add/remove program screen. You get the same error (setuperror.png) one time, press OK, and the install program dies.

You can - however, and this is really wierd - double click on the install program itself and it will run fine.

The 'details' from the error notice are:
Error Code: -5006 : 0x80070002
Error Information:
>Kernel\ServiceProvider.cpp (121)
>Kernel\ServiceProvider.cpp (121)
>Kernel\ServiceProvider.cpp (121)
>Kernel\ServiceProvider.cpp (121)
>Kernel\ServiceProvider.cpp (121)
>SetupNew\setup.cpp (597)
PAPP:MetroPro X
PVENDOR:Zygo Corporation (
@Windows 7 / Server 2008 R2 Service Pack 1 (7601)
IE Version: 8.0.7601.17514

We cannot proceed any further with our release until this issue is solved. The problem seems to be in the deletion of the feature. We have done a few releases with this version of installshield without issue. Deleting a feature is the only new variable for this release. Please help.
Labels (1)
0 Kudos
(1) Reply
Level 6

it seems the error is introduced when the new feature was added.

updating between any of the 3 versions that have this additional feature causes this issue. Note that this new feature is only installed if the user runs Modify.


This is a bit frustrating. Thanks!
0 Kudos