Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Win Explorer doesn't restart when shut down via Restart Manager (RMRegisterResources)

We have a few MSIs that successfully shut down Windows Explorer, but don't restart it about 50% of the time (guesstimate); RmRegisterResources() is used. A number of other functions and methods were also tried (including looking for all process threads and passing them all to the restart manager, killing the oldest process etc.) but nothing has worked thus far.

Has anyone else been seeing this? Any suggestions on how to improve the success rate of restart?

Labels (1)
0 Kudos
(1) Reply
Level 7

Did you ever figure out the solution to this issue? I'm finding the same thing happens to me. Restart Manager will successfully shut down explorer.exe, but some times it will fail to restart it. A look in the event logs shows me this message:
"Application 'C:\Windows\explorer.exe' (pid 5376) cannot be restarted - Application SID does not match Conductor SID.." So, it appears to be some kind of permissions issue, but I'm not sure yet how get restart manager to launch explorer.exe with elevated privileges.
0 Kudos