cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
erics1
Level 3

Visual Studio 2012 version not installing properly

I have installed the InstallShield Limited Edition download for Visual Studio 2012 but when I restart VisualStudio 2012 the only thing available under Setup and Deployment" is "Enable InstallShield Limited Edition". When I select this it just takes me back to the install web screen:

file:///E:/Program%20Files/Microsoft%20Visual%20Studio%2011.0/Common7/IDE/Extensions/InstallShield/InstallShieldProject/1033/InstallShield_pro.html

The installer seemed to run just fine (no errors). I notice that I have shortcuts in my start menu (Windows 7). The shortcut to InstallerShield goes nowhere or does nothing. The shortcut to the help file does bring up a help file.

Can someone please help me with this?
0 Kudos
7 Replies
edmondo_porcu
Level 2

In my case, I have no link in the start menu and the previous project template has disappeared from Visual Studio.

Carefully looking in Visual Studio/Comon7/Ide/ProjectTemplates/SetupAndDeployment/1033/InstallShield

shows that the previous template (the one that brings you to the web page) has been renamed in InstallShield.bak and no new template has been installed. The demos available on the internet shows that after installating, a project template of this type still appear and instead of brining you to a web page, it asks your registration code.


My general feeling is that last build of spring Le installer 2012 is broken.
0 Kudos
Chaitra
Level 9

erics1 wrote:
I have installed the InstallShield Limited Edition download for Visual Studio 2012 but when I restart VisualStudio 2012 the only thing available under Setup and Deployment" is "Enable InstallShield Limited Edition". When I select this it just takes me back to the install web screen:

file:///E:/Program%20Files/Microsoft%20Visual%20Studio%2011.0/Common7/IDE/Extensions/InstallShield/InstallShieldProject/1033/InstallShield_pro.html....




Hi,

There must be some issue with the installation process. Kindly download InstallShield Limited Edition for Visual Studio once again. Close Visual Studio applications, refresh and add a new project. Now, InstallShield gets integrated with the Visual Studio.

Please let us know if this did not help.

Thank you,
Chaitra
0 Kudos
Chaitra
Level 9

edmondo.porcu wrote:
In my case, I have no link in the start menu and the previous project template has disappeared from Visual Studio.

Carefully looking in Visual Studio/Comon7/Ide/ProjectTemplates/SetupAndDeployment/1033/InstallShield

shows that the previous template (the one that brings you to the web page) has been renamed in InstallShield.bak and no new template has been installed. ...

.


Hi,

Kindly update your InstallShield Limited Edition version to InstallShield Limited Edition 2013 Beta for Visual Studio.

Let us know if you have any issues.

Thank you,
Chaitra
0 Kudos
erics1
Level 3

Chaitra wrote:
Hi,

There must be some issue with the installation process. Kindly download InstallShield Limited Edition for Visual Studio once again. Close Visual Studio applications, refresh and add a new project. Now, InstallShield gets integrated with the Visual Studio.

Please let us know if this did not help.

Thank you,
Chaitra


When you say "Refresh" what do you mean? I have uninstalled and reinstalled three times now - does not fix.
0 Kudos
Chaitra
Level 9

Hi Eric,

Could you please tell me the version of Visual Studio 2012 that you have installed?

If it is Visual Studio 2012 Express Edition, then InstallShield Limited Edition does not apply to it. For instructions on getting started with Express, see the following help topic in the Express help:

Creating InstallShield Projects in Microsoft Visual Studio

You can also refer the below link for the same.

Kindly let me know if this did not help.

Thank you,
Chaitra
0 Kudos
erics1
Level 3

That does not help. I have:

Visual Studio Professional 2012
Version 11.0.60610.01 Update 3
0 Kudos
Chaitra
Level 9

Hi Eric,

Thank you for the quick response. So now i understand that it is not an issue related to Visual Studio Edition.

You might have to uninstall Visual Studio as well. Please clear all the registry entries(if any remaining, after uninstallation) by using a registry cleaning tool.

Kindly check if this works after a fresh installation of both Visual Studio and InstallShield Limited Edition.

Thank you,
Chaitra
0 Kudos