Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

Virtual Machine Distribution - Copy Error


I am trying to distribute an installer to a virtual machine after build.

The server config seems correct and it successfully reverts snapshots but fails to copy the setup.exe to the destination path on the virtual machine.

The user account on the VM is correct also and I have tried different formats for destination path and ensuring the destination exists.

Is there a more detailed log than the output view that is normally generated as it just tells me distribution failed?

Thanks in advance.



Labels (1)
0 Kudos
(4) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

You can create a verbose build log using Installshields command line build utility, hopefully this will provide more information for you.  An example of running this would be:

iscmdbld.exe -p "C:\PathToProject\Project.ism" -a "Product Configuration Name" -r "Release Name" -v

The -a parameter specifies the product configuration in the project and -r specifies the release contained in the product configuration to build. The -v option will create a verbose log.

Note that iscmdbld.exe is located in C:\Program Files\InstallShield\2020\System

You can find more information on the command line build here: 

0 Kudos


Thanks for the recommendation.

I followed your guidance and I am still not seeing any extra information around this particular issue.

I've pasted the log below from the verbose output and attached an image of the VM configuration.

Is there something I need to enable on the VM to allow the copy? The snapshot reversal is working fine.

c:\InstallShield 2018 Projects\ISSuiteInstaller>"C:\Program Files (x86)\InstallShield\2018\System\iscmdbld.exe" -p "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller.issuite" -a "ISSuiteInstaller" -r "Release" -v
InstallShield (R)
Release Builder
Copyright (c) 2018 Flexera.

All Rights Reserved.

Build started at Jan 28 2021 12:11 pm
Building Release: Release

spProject->Open Succeeded
ISDEV : warning -5006: Could not save "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller.issuite"
Deleting folder "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages"
Deleted folder "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages" successfully
Creating path "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release"
Creating path "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages"
Creating path "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\LogFiles"
Creating path "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1"
Creating path "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\Interm"
Creating log file: "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\LogFiles\1-28-2021 12-11-18 pm.txt"
Created release folders
Copying from "C:\Program Files (x86)\InstallShield\2018\Redist\Language Independent\i386\SetupSuite.exe" to "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\ISSuiteSetup.tmp"
Embedding manifest SetupExe.Admin.manifest into setup.exe
Embedding file "C:\Program Files (x86)\InstallShield\2018\Support\SetupExe.Admin.manifest" into "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\ISSuiteSetup.tmp"
Copying from "C:\Program Files (x86)\InstallShield\2018\Support\SuiteSetup.ini" to "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\SuiteSetup.ini"
Processing Package 'otp_win32_23.2'
Adding files for Package 'otp_win32_23.2'
Adding File 'otp_win32_23.2.exe' for Package 'otp_win32_23.2'
Processing Package 'otp_win64_23.2'
Adding files for Package 'otp_win64_23.2'
Adding File 'otp_win64_23.2.exe' for Package 'otp_win64_23.2'
Processing Package 'python-3.9.1'
Adding files for Package 'python-3.9.1'
Adding File 'python-3.9.1.exe' for Package 'python-3.9.1'
Processing Package 'python-3.9.1-amd64'
Adding files for Package 'python-3.9.1-amd64'
Adding File 'python-3.9.1-amd64.exe' for Package 'python-3.9.1-amd64'
Processing Package 'rabbitmq-server-3.8.9'
Adding files for Package 'rabbitmq-server-3.8.9'
Adding File 'rabbitmq-server-3.8.9.exe' for Package 'rabbitmq-server-3.8.9'
ISDEV : warning -7337: Feature RabbitMQ Service has no associated packages.
Processing String Tables
Adding Support Files
Deleting file "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\SuiteSetup.ini"
Copying from "C:\Program Files (x86)\InstallShield\2018\Redist\Language Independent\i386\ClrWrap.dll" to "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\Interm\ClrWrap.dll"
Embedding file "C:\Program Files (x86)\InstallShield\2018\Redist\Language Independent\i386\ClrSuitePSHelper.dll" into "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\Interm\ClrWrap.dll"
Deleting file "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\Interm\ClrWrap.dll"
Moving from "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\ISSuiteSetup.tmp" to "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\ISSuiteSetup.exe"
Staging to Virtual Machine
Distribution started on 28-Jan-2021, 12:11:37 PM
Connecting to Image 1E861640-CCC6-4EA0-BA7C-067CA23E27D4
Reverting to snapshot FT-BASEX86 - (14/12/2020 - 16:27:55)
Current state is 0
Copying files from 'C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages' --> ''
Copying files from 'C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1' --> 'Disk1'
Copying 'C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\ISSuiteSetup.exe' --> 'ISSuiteSetup.exe'
Distribution failed.
Distribution finished at 28-Jan-2021, 12:11:52 PM
Launching postbuild events...
BuildEvent: unresolved event 'copy "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\ISSuiteSetup.exe" "C:\Share\Temp\ISSuiteInstaller\ISSuiteSetup.exe" /Y'
BuildEventThread: launching event command line: 'copy "C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\DiskImages\Disk1\ISSuiteSetup.exe" "C:\Share\Temp\ISSuiteInstaller\ISSuiteSetup.exe" /Y'
BuildEventThread: failed to launch event, last error: 2
The Advanced UI or Suite/Advanced UI installation creation process has completed with: 0 Errors and 2 Warnings.
Log file has been created: <file:C:\InstallShield 2018 Projects\ISSuiteInstaller\ISSuiteInstaller\Release\LogFiles\1-28-2021 12-11-18 pm.txt>

Build finished at Jan 28 2021 12:11 pm

c:\InstallShield 2018 Projects\ISSuiteInstaller>


0 Kudos


Is there any else I can try here?

This is still an issue and the build event I am using to copy the output to another location is not working either so it would be great to get these sorted.

I'm working on some events here to with Powershell and seeing some funny behaviour but will be opening up another question around this.


0 Kudos
Level 2


Any update on this issue?

I am having the same problem with "Distribution failed".

After the VM is started the "Distribution failed" is received after about 10 seconds.


0 Kudos