cancel
Showing results for 
Search instead for 
Did you mean: 
deramor
Flexera beginner

Unable to create an IIS 7 AppPool with 32-bit applications enabled on Win 7 64-bit

Hello-

I am trying to install an ISS web site. I am trying to install it on a target system running Win7 64-bit. The website is running a 32-bit application so I need to enable 32-bit apps in the AppPool settings.

I have found documentation however that states this is not possible and the installation behavior seems to agree. The help docs states:

"If the target system has a 64-bit version of Windows, and 64 bit was specified for the ASP.NET platform, the Enable32bitAppOnWin64 property on the target system needs to be set to False. Otherwise, using the 64-bit version of ASP.NET on a system that is configured to support the 32-bit version would cause ASP.NET to become corrupted. Thus, the installation is aborted to prevent damage to ASP.NET services."

What are my options? Do I have any? We are targeting 2.0 framework.
Labels (1)
0 Kudos
2 Replies
KrisVanherck
Pilgrim

Re: Unable to create an IIS 7 AppPool with 32-bit applications enabled on Win 7 64-bit

You can have 64-bit and 32-bit asp.net apps running on the same machine, you just need to put them in separate application pools. I'm guessing you are trying to add them to the default pool (64-bit) which won't work. Simply create a new 32-bit enabled pool.
0 Kudos
deramor
Flexera beginner

Re: Unable to create an IIS 7 AppPool with 32-bit applications enabled on Win 7 64-bit

But it does work. If you configure the AppPool so that it does not allow 32-bit apps from running, then manually change Enable32bitAppOnWin64 to true after the product is installed (via IIS settings), it will work just fine. In fact, the 32-bit app will not run at all until I enable this setting.

It is this observed behavior that I question the help doc. Furthermore, Installshield uses these settings to build the path to regiis.exe. In the correct configuration, this call will fail and the installation will be rolled back. The configuration in question is when Enable32bitAppOnWin64 is initially set to True for a 64-bit AppPool. The path to regiis is constructed in a way to call the 32-bit executable which will not run on a 64-bit OS. So frustrating.

Anyway I worked around it by scripting a change for the property Enable32bitAppOnWin64 after the installation finished.
0 Kudos