cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Marbled
Level 3

Trying to build a project that was converted from InstallShield 2008 causes crash...

Hi!

I am trying to convert a project that was made with InstallShield 2008 to InstallShield 2011 and each time I build it it makes InstallShield crash...

The InstallShield project was using the VB6 objects (I don't remember the exact name they are called in InstallShield) and since this is no longer supported I remove them and want to replace that by a launch of the Microsoft VB6 runtime install program.

Unfortunately it looks like something in that project still doesn't please InstallShield and I get

Runtime Error!
Program c:\Program Files(x86)\InstallShield\2011\System\isdev.exe
abnormal program termination


The event view contains (among other things) this about the crash:

Faulting application name: isdev.exe, version: 17.0.0.714, time stamp: 0x4c564e9f
Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec49b8f
Exception code: 0xc0000005
Fault offset: 0x0002e066
Faulting process id: 0x2d18
Faulting application start time: 0x01cdfb09e6da05b5
Faulting application path: C:\Program Files (x86)\InstallShield\2011\System\isdev.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: 4ddefa54-6700-11e2-8034-005056c00008


The last few lines I get in the "console" before it crash are


Feature:
Building cabinet files data2.cab...
Feature: \Disk<1>
Component: Disk1 Files(1)
Component: Disk1 Files(1)


Can anybody suggest anything I could try to fix this?

Thank you!

Nick
Labels (1)
0 Kudos
3 Replies
Marbled
Level 3

Nobody has an idea?

Is there a way to perform some sort of consistency check on the project to identify the problem?

We have contacted Flexera because we're unable to reinstall InstallShield 2008 to temporarily address this issue (my guess it that most likely the servers/service which are/were used to validate 2008 licences are no longer up) and we haven't heard back from their support guys...

Thank you,

Nick
0 Kudos
Marbled
Level 3

I created a new "release" and this seems to have fixed it...

I get something didn't get properly initialized by the conversion process...

I now have another problem for which I opened a new thread...

Nick
0 Kudos
BizerbaDev
Level 6

Hi Marbled,

thanks for posting your solution. I had the same problem when updating an existing setup solution to IS2012. After creating a new release it worked just fine!!!

Reading your post I'm once againg reminded to the bad support of Installshield, Flexera and Acresso 😞

Regards

Ralf
0 Kudos