Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Suite Project Installscript Custom Action always fails

Hi there,

I want to run a Installscript function (test) as a custom action in a Installshield Suite Project. The Installer shows the splashscreen and then ends.

CustomAction1 .png

I already deleted all commands in the function and reduced the function to do nothing (but the fuction still fails):

CustomAction2 .png

This is what the debuglog says:

11-2-2022[11:30:44]: Running event 'Test'
11-2-2022[11:30:44]: Launching InstallScript action in function 'test'
11-2-2022[11:30:44]: Engine: request for proxy handler, 0, 0
11-2-2022[11:30:47]: Action returned value 0x8002000e
11-2-2022[11:30:47]: Action 'Test' returned status 0x80070643
11-2-2022[11:30:47]: UI DLL: Shutting down
11-2-2022[11:30:47]: Original exit status: 0x80070643, final exit status: 0x00000643
11-2-2022[11:30:47]: State manager: removing staging files from: C:\Users\USER1~1.TRA\AppData\Local\Temp\{0BBE8C94-B9D5-4CC9-B8B5-B40814CA107F}\
11-2-2022[11:30:47]: State manager: removing state info

I use Installshield 2019R3 (Version 25).

Any ideas what I can do to run a custom script successfully?




Labels (1)
0 Kudos
(2) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

All things being equal the steps you've followed should work - I ran a quick test here and my test Installscript custom action ran from the suite.

Windows error 0x80070643 has been reported as an issue with a corrupted .NET Framework. Try uninstalling and reinstalling your .NET framework to see if that helps.

Also test the installer on multiple machines to see if the problem is only happening on one or all.

0 Kudos

Thanks for your reply.

I tested this on several machines (Windows Server 2016 and Windows 10) with the same result. That the .Net Framework is corrupt is highly unlikely because our software uses .Net Framework and runs perfecly on all test machines.

Any other ideas or something I could try?

0 Kudos