Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Strange problem with Major Update


I have encountered an odd problem when I (sometimes) do a major update and apparently I have inadequate google skills. It doesn't always occur, but then again, I doesn't do major upgrades using the repackager that often (once a month, maybe?).

The scenario:

I make a snapshot using the repackager. The program doesn't come with any kind of install, it's just a bunch of files and com dll's. Nothing odd here.

The first version installs properly.

When it's time to upgrade I do a new snapshot, copy the Upgrade code and create a major upgrade that uninstalls the older version.

But here's the catch: SOME files doesn't get reinstalled after the old version is removed, both exe and dll files.

A verbose log doesn't reveal anything; every file seems to be installed.

Comparing files in Installshield, even in the Direct Editor, doesn't show any differences between those that gets installed and those that doesn't.

It's the same files every time I run the same scenario that is missing, ie it's not random.

Running the same install a second time or repar the install, installs the files.

Starting the program using an advertised shortcut repairs the missing files.

Running the install on a computer without the old version installs everything.

No files are locked, they get removed just fine.

Same thing on all my virtual machines regardless if it is XP or Win7 x64.

I marked some files as permanent, but they still gets removed and the problem persists. I must have missed something here...

I haven't tried to create a new project without using the repackager. My workflow used to work just fine.

Any ideas?

Edit: Did a completely new snapshot of the same files. Same problem.
Labels (1)
0 Kudos
(2) Replies
Level 3

Are the missing files versioned? If so, are the versions changing with the upgrade?
0 Kudos
Level 3

ajonasson wrote:
Are the missing files versioned? If so, are the versions changing with the upgrade?

Thanks for replying.

Yes, all files affected seems to have a version. Some files have the same version (and are byte by byte identical, ie it's the same file) and some files have a lower number. (This is, however, not entirely unusual when it comes to many of the programs I manage. Some developers seems to ignore versioning alltoghether).

None of the files are newer (according to their version).

I have been deploying applications for five years now or so and never encountered this particular problem before.

We always update Installshield to the latest version. Don't know if one thing got to do with another, but this started occuring during IS 2011.

Edit: Checked a few files that DO get written; same version number.
0 Kudos