cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
DLee65
Pilgrim

Strange issue with installing windows features on Server 2012

I am running into a problem with the execution of the NetFx3 feature on Windows Server 2012.

If I have a very clean VM without any roles enabled, install will fail. Even running the DISM command from powershell with admin rights will fail.
However, If I go to Programs and Features to enable the feature it will succeed.

If I go and enable a role, lets say Application Server, and restart; then the install will work.

The error from the suite debuglog:
Failed to DismEnableFeature (NetFx3ServerFeatures;NetFx3): error 0x800f0906, 'The source files could not be downloaded.
Use the "source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.

Any ideas on why we are seeing this behavior and any suggestions on a work around for this, or at least a check to see if a condition exists prior to this installing?
This has been reproduced on Windows Server 2012 Datacenter and Standard.
Labels (1)
0 Kudos
2 Replies
rguggisberg
Active participant

Re: Strange issue with installing windows features on Server 2012

Dan,
It is working for me. I am simply adding NetFx3 under Packages - Common - Windows Features. Is that what you are doing?
I also have 'Require Elevated Privileges' set to "Yes".
Keep us informed. Do you want me to do a log and see what I get in that area?
0 Kudos
DLee65
Pilgrim

Re: Strange issue with installing windows features on Server 2012

I am not seeing the option to 'run as administrator' or any other similar option as I go through the wizard in Windows Server 2012 Datacenter.

When I go to Programs and Features and select the option to add a feature on the left, then the Add Roles and Features Wizard starts. I step through and do not select any roles just the option for .NET Framework 3.5. I then click Next. I have tested with the option to Restart the destination server automatically if required too.

For me the install just hangs for a very long time and then eventually will error out.

One of my coworkers in QA can get this to work if he switches his vm network protocol from NAT to Bridged. We are using workstation 10.
For me this does not make any difference.

Note that this is a very clean system and no windows updates have been installed either. I am not sure if this makes a difference in your testing.

I am now testing to see if running Windows Update resolves the problem.

EDIT: I ran windows update once and then tried to enable the role and it works after doing this on my VM system. I believe QA already had run windows update but it required them to change from NAT to Bridged for their VM network settings.
I am now testing running the Suite setup package after having run windows update. If it is just a windows update issue then I am less concerned about this for production as I would expect everyone to have run Windows update at least once before our product gets installed.

EDIT2: After resetting the VM to the base image without any windows update, I installed all windows updates. After installing all windows updates and rebooting, as prompted, I then tried my application and it is working as well. So the issue seems to be primarily if it is a new system that does not have any windows updates.
0 Kudos