cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Tyleeg
Pilgrim

Small update not installing new file

Greetings, I have 2011.
Between 2 packages having the same version, I have added a new component to an existing (previously empty) feature, and marked the file as shared.
The only diff between the two packages, other than the new component and file, is the package code.

On clean installs, the new package successfully installs this file. It also reinstalls it on a repair if the file is removed.
As well on upgrades from a prior version of the package, it also gets installed properly.

However, updating from the prior package, it does not install it.

The log entry related to this new component shows this:
MSI (s) (8C:08) [08:40:01:101]: Component: bin_dthres32; Installed: Absent; Request: Null; Action: Null

The feature to which I added the component shows this in the log:
MSI (s) (8C:08) [08:40:01:100]: Feature: bin; Installed: Null; Request: Null; Action: Null

The feature in question, is a sub-feature, if thats relevant.

From all that I have read, this should work.

Can someone point me in the right direction?
Cheers,
Ty
Labels (1)
0 Kudos
1 Reply
Tyleeg
Pilgrim

Re: Small update not installing new file

For the record... it appears that since this sub-feature already existed with no components attached to it, it was never considered as 'installed'. So adding a component to it in a later package would not install that component. - During a small update
I addressed this by moving the component up one level to a feature that was considered installed
0 Kudos