cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
tobrin
Level 3

SigningHelper: error 0x80070057 while attempting to sign file

I have just upgraded to Installshield 2016 from 2014 and now i got this error in the build log when i try to sign my output files. What could be the reason to this?

SigningHelper: error 0x80070057 while attempting to sign file
Labels (1)
0 Kudos
6 Replies
joshstechnij
Level 10 Flexeran
Level 10 Flexeran

Were you using a PFX or SPC/PVK certificate in IS 2014? IS 2015 and newer no longer support SPC/PVK certificates. These can be converted to PFX style certs if needed.

If you are using a PFX, what are the settings listed in your release on the Signing tab in the Releases view? Error 0x80070057 indicates an invalid parameter, so these settings could be an issue.
0 Kudos
tobrin
Level 3

joshstechnij wrote:
Were you using a PFX or SPC/PVK certificate in IS 2014? IS 2015 and newer no longer support SPC/PVK certificates. These can be converted to PFX style certs if needed.

If you are using a PFX, what are the settings listed in your release on the Signing tab in the Releases view? Error 0x80070057 indicates an invalid parameter, so these settings could be an issue.


My settings are as follows:

Certificate URL: http://www.tbd.com
Digital Certificate Information: File: \authenticode.pfx, Digest Selection: Based on certificate hash
Password: ********
Sign Output Files: Setup.exe and Windows Installer Package
Signature Description:
Sign Files in Package : No


The password contains underscores, hashtags and alphanumerics ( If i change it i get the correct error 0x80070056 (invalid password) instead. )
0 Kudos
tobrin
Level 3

joshstechnij wrote:
Were you using a PFX or SPC/PVK certificate in IS 2014? IS 2015 and newer no longer support SPC/PVK certificates. These can be converted to PFX style certs if needed.

If you are using a PFX, what are the settings listed in your release on the Signing tab in the Releases view? Error 0x80070057 indicates an invalid parameter, so these settings could be an issue.



My settings are as follows:

Certificate URL: http://www.tbd.com
Digital Certificate Information: File \authenticode.pfx, Digest Selection: Based on certificate hash
Certificate Password : ***********
Sign output Files: Setup.exe and Windows Installer Package.
Signature Description :
Sign Files in Package : No
0 Kudos
tobrin
Level 3

My settings are as follows:

Certificate URL: http://tdb.com
Digital Certificate Information : File \authenticode.pfx, Digest Selection: Based on certificate hash
Certificate Passweord: *********
Sign Output Files: Setup.exe and Windows Installer Package.
Signature Description:
Sign Files in package: No

If i try to change the password i get the correct password error ( 0x80070056 )
0 Kudos
joshstechnij
Level 10 Flexeran
Level 10 Flexeran

These settings all appear to be valid (assuming the .pfx exists, but that shouldn't be the issue since you can produce an invalid password error).

Can you check the following:
- Are there any -1027 build errors or warnings after the 0x80070057 message? If it is a -1027 warning, this indicates the file in question was signed but didn't timestamp correctly. Do your setup.exe or .msi files have digital signatures but no timestamps?
- As a test, create a new network image release (default settings) and configure the signing settings as you have on your existing release. Does this release sign and timestamp the setup.exe and .msi files?
- If the above test fails, try creating a new project, add one feature, one component, and one file. Create a release in the project that includes your existing signature settings then build the release.

Based on the above, this could help isolate if this is a signing problem, a timestamping problem, or some other issue. Please let us know the outcome of the above tests.
0 Kudos
tobrin
Level 3

Ok i understand. The error was just a warning...

I can see that my files are signed without timestamps just as i wanted.

Thank you for your assistance.
0 Kudos