marcovdlinden
Level 4

Short cut Icon fails on 32bit install on 64bit os

Question: How to set the Icon for the desktop shortcut with installshield on a 64 bit os for a 32bit application

This is what I added under System Configuration - Shortcuts
Icon: \MyIcon.ico,0 (the ,0 is added by IS when choosing MyIcon.ico)
Target: \MyExe.exe
Working Dir:

I'm installing a 32bit application on Windows Server 2008 64bit

It translates in to
C:\Program Files (x86)\.... for both the working dir and the executable

But.......
The Icon is a white squar, when I select the option change icon it give me the warning:
Windows cannot find the file %ProgramFiles%\.....

And that I can understand as well since %ProgramFiles% translates to c:\Program Files\ on a 64 bit os.. and not what it should be C:\Program Files (x86)\....
Is this a bug? Or am I doing something wrong?

Note: When I manualy try to change the shortcut, and when I inspect it again windows has replaced C:\Program Files (x86)\.... with %ProgramFiles% (x86)\... which works.
Note: I use \MyIcon.ico for the Add\Remove program icon, which works just fine.

Fails on:
Windows server 2008 64 bit
Windows server 2004 64 bit (not tested myself)
Windows vista 64 bit (even after the sugested reboot)

[edit: updated with most of the comments below]
Labels (1)
0 Kudos
10 Replies
ericpaul
Level 6

Just to be sure: did you really use %ProgamFiles% (instead of %ProgramFiles%) or is this a typo in you message?
0 Kudos
marcovdlinden
Level 4

I didn't do anything 🙂 Installshield translated my in to


but yeah, I made a typo copying the result when I inspected the desctop icon that was created. It is the correct windows %% except that on a 64 bit system it points to \Program Files\ while my app was installed in \Program Files (x86)\

I am just wondering why is translated twice to the actual path, but for the icon its stranslated using %ProgramFiles%
0 Kudos
marcovdlinden
Level 4

Some more research. It seems that the OS rewrites the icon file location.
replacing C:\Program Files (x86)\... with %ProgramFiles%

But, when I manualy make a shortcut it makes:
%ProgramFiles% (x86)\... Which works.

So still the question remains why installshield can't set the custiom icon on a shortcut on a 64 bit machine (it fails on 64bit win 2003 as well).
0 Kudos
adnirtech
Level 2

I had the same problem and even had a case on it with Flexera. They could never repeat the problem even though I could all the time. This was a while ago so I don't rember all the details but I think it only happend after you run the installer a second time with out a reboot. The first time after reboot it seemed to always work. I know I tried some other things that helped but I would have to go back and look if you need more info. Let me know if that helped.
0 Kudos
marcovdlinden
Level 4

Thanks for the tip, I usualy dont reboot the machine that I was testing on.

However, I tried on a freshly booted Vista 64 bit machine.
The problem is still there.
0 Kudos
rguggisberg
Level 13

I do this all the time with no trouble.
Try replacing TARGETDIR with INSTALLDIR.
0 Kudos
marcovdlinden
Level 4

INSTALLDIR results in the same problem 😞
0 Kudos
maforshaw
Level 5

I think this is the same problem I had and InstallShield Support reproduced it. However, they are blaming a broken Windows API call in 64-bit Windows so see it as an enhancement request :rolleyes:

The tracking number is #IOA-000054009 and may be resolved in some future version...
0 Kudos
alex_yuner
Level 2

Hi all,
anybody knows if this bug is solved??

Thanks and best regards,
Alex
0 Kudos
VonHatte
Level 2

Having same problem... Any fix or workaround found yet?
0 Kudos