Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

Setup will not create minor upgrade

Jump to solution

Hello I am trying to create a new setup program that does a minor upgrade of a previous setup.  This is failing on the build with the following error:

ISDEV : error -6423: The project contains a Minor Upgrade item that references the setup C:\Users\devadmin\AppData\Local\Temp\8985\RecFind 6 SDK.msi. However, the referenced setup can only be upgraded with a Major upgrade. Please use the Major Upgrade item or the automatic upgrade item. 

So its telling me that it cant do a minor upgrade; the documentation says that the prerequisites for a minor upgrade are that the the Package Code is updated, that the version number should be incremented, and that the Product Code should be the same.   I have done all of those things and it hasn't helped.

Also I have tried validating the setup.exe that I am trying to upgrade from in the Upgrade page.   It gives me this result:

Val0003	This setup will perform a SMALL upgrade of the referenced previous setup	c:\users\devadmin\appdata\local\temp\2245\recfind 6 sdk.msi
Val0003	The package code for the latest setup does not differ from that of the previous version.  In order to perform an upgrade the package code MUST change.	c:\users\devadmin\appdata\local\temp\2245\recfind 6 sdk.msi
Validation Complete!

1. it tells me that it will do a small upgrade which does not actually happen,
2. it says the package code needs updating which I have done; 

Note that I was originally having this problem in installshield 2015, and tried again using 2019, but got the same error.


0 Kudos
(1) Solution

Looks like it was due to a typo on the product code. Thank you for your assistance .

View solution in original post

0 Kudos
(6) Replies
Level 5 Flexeran
Level 5 Flexeran

Hi @emmanuelc,

Can you try the solution from the following KB article:



0 Kudos

Thank you for your reply, I had already seen that page.   It tells me to change to a major upgrade. Otherwise;-

"If you must use a Minor Upgrade item, you need to compare the latest version of the project to the previous version and ensure all the criteria in the Cause section above are met. Once these criteria are met, a minor upgrade should build correctly with no errors."

I have compared all the criteria, and a minor upgrade does not build.   Frustratingly, it does not tell me what criteria failed.   Is there a way to find that out?



0 Kudos

Hi @emmanuelc,

Just for my information, I hope that you are creating 2 Releases, one for original version (v1.0) and another for Upgrade (v1.1).
For Example:
Release 1 (version 1.00.0000)
Release 2 (version 1.00.0001)


Or if it possible for you to share a sample project where you are able to reproduce the same problem.



0 Kudos

Sorry did not understand your question.
I have a setup program from 2 years ago that was built with InstallShield 2014.

I no longer have the ISM that built it in its original form; this was before I started at this company.   The file I do have looks like it might be the same, but I don't know what might have changed.

I am trying to modify the ISM that I do have to create an install for an upgraded version of the software.  When I run it, I expect it to create a minor update.

Ie. I have a old setup program version 2.9 and a new ism set to version 2.10

I have set the product code and package code and version number in line with what the documentation says it should be.

The build gives an error when I try to create a minor upgrade with an error that says it cannot build a minor upgrade, but does not tell me why.

The validation tells me it will do a minor upgrade, but it doesn't work.

If I create an automatic or major upgrade, then it builds, but creates a new install on the target machine.   So its not an upgrade at all, its a new install.

I just need this software to create an upgrade of an existing install, or to tell me why it cant.

I have attached the new ISM for v2.10 and the old setup for v2.9 to this message.

Thanks for your help. 




0 Kudos

Looks like it was due to a typo on the product code. Thank you for your assistance .

0 Kudos
Level 2

I attempted to introduce Clip Studio Paint 1.9.4. Everything goes fine until after go foward from language area, the installer crash at specific point with "InstallShield Setup Launcher Unicode has quit working" and it happens too with prior renditions to 1.9.4.

Not going excessively far, my pc is a 32 pieces machine with Windows 8.1 professional, i've organized it multiple times and still not ready to introduce CSP, attempted with running it as an administrator, with similarity mode and utilizing an alternate windows account, does nothing.Please I don't need questions or replies about my pc's arquitecture, all I need is work now. To clear things, no, the installer is from Clip Studio site and isn't 64 pieces, in the event that it was, in the lead position my framework won't ever run it and simply giving a SmartScreen message about arquitecture inconsistency. Before this, my pc had the option to introduce any CSP form and running it with no issue.

0 Kudos