cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

Re: SQL Express 2014 Silent install fails when called from Installshield Prerequisite

dana_lizuca wrote:
Hi,

Did anyone find a solution to this?

Dana


hi,

To solve failed extraction problem, you just have to add this paramter into your command line : /q /x:c:\SQL

/x can't be used with /QS value and "c:\sql" is just an example

But after this, you will have another problem !!! the famous "bootstrapping" and /SkipInstallerRunCheck doesn't work.with installshield (or i don't know how to do)

the only way is to create an Aui suite setup but for me it's a nightmare !
0 Kudos
Highlighted
Flexera beginner

Re: SQL Express 2014 Silent install fails when called from Installshield Prerequisite

This sounds similiar to a problem I had with SQLExpress 2012.

As someone suggested earlier the solution is with the parameter SkipInstallerRunCheck=1

However, instead of passing this as a parameter to the SQLEXP prerequisite, you need to set this as a property in the installer calling the prerequisite.
0 Kudos
Highlighted
Pilgrim

Re: SQL Express 2014 Silent install fails when called from Installshield Prerequisite

Did anyone find a solution to this?

For me is giving the following error:

05/04/2016 16:21:14.873 ======================================================================
05/04/2016 16:21:14.881 Setup launched
05/04/2016 16:21:14.887 Attempting to determine media source
05/04/2016 16:21:14.890 Media source value not specified on command line argument.
05/04/2016 16:21:14.892 Setup is launched from media directly so default the value to the current folder.
05/04/2016 16:21:14.893 Media source: C:\Users\W7\AppData\Local\Temp\{1C2AC8B6-F2F3-4866-9F3E-C75F4AC8410A}\{651D8985-1F7B-4867-8AF6-86082D34F0DF}\SQLEXPR_x86_ENU\
05/04/2016 16:21:14.896 Attempt to determine media layout based on file 'C:\Users\W7\AppData\Local\Temp\{1C2AC8B6-F2F3-4866-9F3E-C75F4AC8410A}\{651D8985-1F7B-4867-8AF6-86082D34F0DF}\SQLEXPR_x86_ENU\mediainfo.xml'.
05/04/2016 16:21:15.188 Media layout is detected as: Core
05/04/2016 16:21:15.191 Media is a slipstream package
05/04/2016 16:21:15.193 Only patch related actions can run patch setup.exe, so continuing to run setup.exe from media.
05/04/2016 16:21:15.217 Error: This OS is not supported
05/04/2016 16:21:15.226 SQM key not found
05/04/2016 16:21:15.231 Setup closed with exit code: 0x84C40034
05/04/2016 16:21:15.238 ======================================================================

Ive searched all over the internet but everybody is saying that is not possible this configuration.
Could someone help me?
Thank you
0 Kudos