cancel
Showing results for 
Search instead for 
Did you mean: 
kiwixou
Pilgrim

Replace the JVM during an update

Hi all, I know this is an old product but maybe someone will be able to help.
Well the problem is quite simple, I'd like to update our software. This software will rely on a newer jvm: we switch from java 1.5 to 1.6.

I created the jvm bundle, no problems. The installation from scratch works perfectly, the application relies on java 1.6.
However when I run an update, the jvm is not updated, it remains in 1.5.

I tried to delete it just before the JVM resolution, it didn't work... worse, the 1.6 jvm wasn't even installed. I tried different configurations of the JVM resolve action, nothing solved my problem. Same with what's been recommended here http://community.flexerasoftware.com/archive/index.php?t-169768.html, it didn't do anything.

This is very frustrating...

Thanks,

Jerome
Labels (1)
0 Kudos
1 Reply
kiwixou
Pilgrim

Re: Replace the JVM during an update

Finally got it to work... note that the jvm installed is dedicated to our software, it's not the same as the one used by the installer/uninstaller.
When updating, I delete the jvm folder and redo the JVM resolution. It looks like that:

1/ Uninstall JVM action (uninstall production action targeting the JVM resolution at 3/)
2/ Delete the jvm folder
3/ JVM Resolution. We use installed JVM = False and bundled JVM

It works however it's dirty.
0 Kudos