Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Quick Patch


I am trying to build a simple quick patch with IS 2021 Premier. On at least 1 Windows 10 machine I get a pop up when installing the patch.

"MDAC 2.7 SP1 cannot be installed on this machine..."

I have not included any MDAC prerequisites and this does not happen when installing the baseline msi... only when installing the patch. Why is this happening? My understanding was that MDAC 2.7 Sp1 was deprecated years ago.

Nothing in the patch requires MDAC. It is just a test patch, so the only change is one file that I rebuilt with an incremented version number.

Thanks for any ideas.



Labels (1)
0 Kudos
(5) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Try using Installshield's direct edit mode to manually view the .msp patch file. This will show you what has exactly been built into the patch and will allow you to see if any MDAC files are present.
Simply right click the .msp file and select edit with Installshield.

If there are issues with the operating system then there may be logic in your installer that attempts to install MDAC - which is failing as the version its trying to use is not compatible.

Try downloading and installing the latest MDAC onto the OS in question:

0 Kudos

@shunt, Thanks for your reply.

Unfortunately, the direct edit of the .msp file shows no MDAC files. We did download and successfully install MDAC 2.8 on the target machine and we still get the same result when applying the patch. "MDAC 2.7 SP1 cannot be installed on this machine...". 

This is puzzling because it is Windows 10 64 Bit and I believe that MDAC should already be baked in to the OS. Furthermore, this only happens when attempting to install the patch, which only contains 1 file that simply has the version updated from the original file. This does not happen on other Windows 10 machines.

Thanks again for your help.

0 Kudos

Additional info:

Just discovered that this problem only occurs if I double click on the .msp file to execute it. It works just fine if I open a CMD prompt, CD to the folder containing the .msp file and run this command:

msiexec /qn /p PatchPackage.msp REINSTALL=ALL REINSTALLMODE=ous

What does that mean?


0 Kudos

It definitely has something to do with the user interface.

msiexec /qn /p PatchPackage.msp REINSTALL=ALL REINSTALLMODE=ous


msiexec /qb /p PatchPackage.msp REINSTALL=ALL REINSTALLMODE=ous

work just fine. This does not...

msiexec /p PatchPackage.msp REINSTALL=ALL REINSTALLMODE=ous

Does that provide a clue?

0 Kudos

Figured it out and replying in case anyone else runs into this. I logged the install of the patch a while back, but did it with reduced UI. That showed nothing. Now I logged it with full UI and see that the install got an error on things related to some CA's that the patch installer added to 'Help me' ??? Things like Check for MDACInstall.C9C35FC7...". I unchecked al the CA's with "C9C35FC7..." and now it works fine.


0 Kudos